Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I installed Windows 7, booting lasted for about 40 seconds. Then I installed VS2010 and booting is 20 seconds longer. In task manager I see SQL Server process running. Is there a way to disable these programs at startup and fasten booting?

share|improve this question

You can control service startup in the services management console plug-in. Just:

  1. Start | Run
  2. Type services.msc
  3. Press enter

You'll find various services with names starting with "SQL Server". Just double-click to get the Properties dialog, choose either Disabled or Manual in the Startup type drop-down box, and click OK to save. (Manual makes it easy to start them when you need them, but it also means VS 2010 can start them without asking you [I don't know whether it does that, I'm just saying].)

share|improve this answer
Or if the service is needed you can choose the Automatic (Delayed Start) option – Nifle May 29 '10 at 10:57
I'd actually go for "manual", because you don't need them running the background all the time, but you want to be able to start them from a script at some point. – Joel Coehoorn May 29 '10 at 13:29
@Joel: Yeah, I was thinking that later. I've updated it. – T.J. Crowder May 29 '10 at 13:58

What I do in the services section is set the Startup type to manual. Then I create a pair of batch files on my desktop. In that batch file I place the following two lines:

NET START <Sql Server Instance Name>
NET START <Sql Server Agent Instance Name>

That way when I need to run SQL Server, I can quickly start it without having to back in through the Services panel. Replace START with STOP in the other batch file to shut it down on command again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .