Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed Wireshark(.org) using Homebrew.

brew install wireshark

at the end the script says

==> ./configure --prefix=/usr/local/Cellar/wireshark/1.2.7 --disable-dependency-tracking --disable-wireshark
==> make
==> make install
==> Caveats
We don't build the X11 enabled GUI by default
==> Summary
/usr/local/Cellar/wireshark/1.2.7: 167 files, 50M, built in 5.4 minutes

I'm not able to find the 'wireshark' GUI.
Any idea of how to build it?


share|improve this question
$ brew options wireshark

Shows you options for wireshark, which lists --with-qt. QT is the GUI toolkit that Wireshark uses since 1.10. Thus, install wireshark using the following command:

$ brew install wireshark --with-qt

Or if you already have wireshark previosly:

$ brew reinstall wireshark --with-qt
share|improve this answer
Note that beginning with Wireshark 1.10.0 QT is used instead of GTK. So you can use the option --with-qt – hanxue Oct 21 '13 at 15:00
brew reinstall wireshark --with-qt – Louis May 17 '14 at 12:56
First time I've ever had a formula not install by default. It would be better if there was a --without-gui instead of blindly continuing without any GUI which most who install wireshark are probably expecting. – Sukima Aug 6 '14 at 16:44
@hanxue how do I run it after installing it? – Zoltán Sep 3 '15 at 14:15

The new approach is to use brew install wireshark --with-qt.

The --with-x option no longer works.

More details on the switch to QT:

share|improve this answer

Well, the system did warn you that it wouldn't install the X11 GUI. So maybe there is an option in the configuration phase that enables it? You'd need a whole extra set of stuff to run X11.

At there is a binary downstaller you could use...

share|improve this answer
Thanks for your response. I've X11, I just don't understand what I'm missing. I should build wireshark gui in some way I suppose... no mention of how to do it with homebrew. this is the script '…; sorry I'm newbie – miku8 May 29 '10 at 14:58
Do it without the --disable-wireshark in the script. So edit the script... Maybe you'll get a problem with dependencies as well, so you could remove the --disable-dependency-tracking as well, but then of course you could get errors as well.... You do know that at the wireshark site there is a complete binary build of wireshark, installer and all ? That's a lot easier. – Henno May 29 '10 at 17:53

There is a Mac .dmg app installer from the website. You must wait a while for it to start X11. It will seem as though it is not working, but the app is just very slow.

share|improve this answer

You appear to have disabled the building of the GUI with the --disable-wireshark option to the configure script .

You need to clean up from the previous build, run configure without the --disable-wireshark and then rebuild.

Unfortunately I can't help you do this on your OS as I have no knowledge of it.

share|improve this answer

My reputation is too low to comment on @jonchang's answer, and I realize that this is old, but in case others find this...

brew install wireshark --with-qt

as indicated in @jonchang's answer worked for me (use brew reinstall wireshark --with-qt, as mentioned by @Louis if you've already installed wireshark without qt).

As for running it, it doesn't install an OS X application, but you should then be able to run qt from the command line:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.