Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to get Zend Framework working with netbeans, but every time there is the error

"php.exe"' is not recognized as an internal or external command, operable program or batch file.

I am using WAMP server 2.0 it is installed in e:\wamp

My Zend framework is inside e:\wamp\www\ZendFramework-1.10.5

I have located the ZendFramework script as: E:\wamp\www\ZendFramework-1.10.5\bin\zf.bat

I am also registered the module.

What am i doing wrong?

I am running on Windows 7 32 bit, using NETbean 6.9 RC1

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The file E:\wamp\www\ZendFramework-1.10.5\bin\zf.bat is trying to execute php.exe. This is probably in the E:\wamp\bin\php folder. Move the contents of e:\wamp\www\ZendFramework-1.10.5 to E:\wamp\bin\php or try editing the batch file (zf.bat) with notepad to change the command that executes php.exe so that it points to the right path.

Check this out: http://samsami2u.wordpress.com/2008/07/18/phpexe-is-not-recognized-as-an-internal-or-external-command/

share|improve this answer
    
thanks philia, I was banging my head for hours due to this –  Starx May 29 '10 at 16:57
    
You're very welcome –  BloodPhilia May 29 '10 at 17:29

Try adding the bin directory containing 'php.exe' to your windows path. To do this (on Windows 7):

  1. Click Start button, right-click Computer, open properties.
  2. Select 'Advanced system setting'.
  3. Click 'Environment Variables' button.
  4. In 'System variables' section, select the 'Path' variable and click 'Edit...' button below.
  5. Append to the end of the text the following (for default wampsever setup, may be different for other setups)(without the quotes) ";C:\wamp\bin\php\php5.3.0"
  6. Click OK a few times to close all the windows you just opened.
  7. Relax and get a brew, you're done :)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.