Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My asus p5k deluxe motherboard and e6600 processor are reported as not having hardware DEP (Data Execution Prevention) in Vista's DEP setup panel. I need to test the software I write with a machine with hardware DEP, so I guess I need a newer system. Can I just get a newer 775 socket processor, or will a new motherboard be required as well?

share|improve this question
up vote 4 down vote accepted

This is a bug in Vista then. All modern Intel and AMD x86 processors support the NX/DX bit. Oddly, I've never heard of XP or Vista not able to detect this properly. You can check your bios settings to see if there is a way to disable it from there. I know Virtualization can be turned on or off from a bios setting in most motherboards. I've never seen DEP settings in the bios but anythings possible.


I was browsing the Manufacturer's faq. You probably need a bios update to enable DEP. The processor does have it built in but the Motherboard has to take advantage of it.

You may or may not have to reinstall Windows for it to detect it properly. In any case I'd back up critical data before doing a bios update. You shouldn't have any trouble but if something goes wrong during a bios update it can turn your system into a boat anchor.

share|improve this answer
Oh, didn't know the details ty. Could it be a setting in my bios configuration causing the problem? I don't recall seeing a setting for this. – P a u l Jul 28 '09 at 20:45
Ok my bad. There is a cpu 'execute disable bit' setting in the bios. Set it to enabled and hardware dep is working. – P a u l Jul 28 '09 at 20:56
Don't forget to mark this question as answered. It lets people looking for the same answer know you found what you were looking for. Plus it gives the answerer reputation points :D – Kenneth Cochran Jul 28 '09 at 21:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .