Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a 1080p 22" Samsung Syncmaster 2333HD (connected via HDMI) and the picture and video quality is great but the text quality is absolutely horrible. This monitor has a built in HD TV tuner.

Even as I type now all the text in this text box as well as in the browser toolbar and start menu, etc looks weird - like it all has a white outline around it that makes it jagged and hard to read. It hurts my eyes just to look at it.

I am running my PC in the suggested native resolution of 1920x1080, so what's the problem?

Is this one of the unavoidable downsides of using a HD monitor? Is there a solution to the problem?

share|improve this question
    
Is this an HDTV you're using as a monitor? If so, what model is it? –  Michael Todd May 30 '10 at 3:35
3  
To follow up on Michael's comment, if they are HDTVs they you need to turn off deblocking and disabling the "sharp" filter on your TV. My Sony had a sharpening filter that destroyed the font smoothing effect applied to text and made it look bad. –  ta.speot.is May 30 '10 at 5:07
3  
Samsung? Throw it out. >.> | Try calibrating Win 7's Cleartype. | Also if there is a HDMI on the Display, use THAT. If not, use DVI. But please do NOT use VGA(d-sub). –  Shiki May 30 '10 at 7:15
    
@Shiki I am using HDMI though I don't think I am rich enough to through away the monitor just yet. –  Laura May 30 '10 at 14:20
    
A screenshot would help, I think. –  Sasha Chedygov Dec 20 '10 at 4:58

8 Answers 8

I'm using Samsung P2370HD on HDMI connection. The text was really bad when I first started using the HDMI connection (R6850HD), Even lowering the sharpness doesn't make it as it should be. After one day of googling, I found the solution is very simple and that is you just need to rename the HDMI connection name to PC from your Monitor Setup. You can do it from your Samsung remote controller as following:

  1. Press the "Source" button.
  2. Highlight the HDMI input.
  3. Press "Tools" -> Edit Name -> And then simply using the scrolling (up & down keys on ur remote), select "PC" or "DVI PC" for your HDMI. And voila you have crystal clear text just as on DVI.

But remember that if you select DVI PC, you will not get sound through HDMI cable. Select "PC" and you will have both sound & video, and clear text.

share|improve this answer
    
The same helped for the Samsung B2330HD, with slightly different menu options: MENU -> SETUP&RESET -> PC/AV Mode -> PC. –  Ralf Oct 24 '13 at 7:23
    
+1 Worked perfectly. Thanks. –  SpiritMachine Nov 12 '13 at 3:26
    
I've got a Samsung SyncMaster S27B350, which worked fine with my desktop, but when i connected my laptop to the second HDMI, the fonts were terrible. The advice about changing the name of the input worked for me. Menu::Source List::Edit Name::HDMI2::PC And everything looked better. I notice this also changes Menu:Mode from "Standard" to "Entertain". Thanks all! –  user297560 Feb 5 at 22:24
1  
So glad I found this, I've got a Samsung UE32F5000, I'd forgot about HDMI issues like this so it was annoying. I set it to DVI PC and it looks great now, talk about hiding a setting. I use separate speakers so the audio part is not an issue for me so I didn't test that. This also meant that I didn't need to use 'Smart Fit' for the picture size, it got 16:9 and didn't cause the overscan problem. Thanks. –  Kioshiki Feb 17 at 20:21
    
Thanks a lot! This solved it in my SyncMaster P2270HN. The option was in Menu -> Input -> Edit Name. Changed to PC and the picture and scaling were fixed. –  Fabio Gomes Aug 20 at 2:23

Just set up a Samsung B2330HD on a HP DV7 laptop with an HDMI out. Text looked bad until I went in and LOWERED the sharpness from 55 to 10. Text looks much better now.

share|improve this answer
    
Thank you! My new Samsung TV that I use for my game pc when from horrible to awesome with lowered sharpness! –  alkemann Aug 5 '12 at 15:54
1  
Sharpness and other 'enhancement' features should be shut off entirely so the screen only shows what the graphics card is sending it, and no extra data it invents. –  mikebabcock Oct 2 '12 at 3:08
    
Making the sharpness too low makes all the text blurred. I suggest changing the PC/AV Mode first. –  Ralf Oct 24 '13 at 7:26

Is your PC running Windows XP? If so, do you have ClearType turned on? Does it look fine on a normal monitor?

On Windows XP, ClearType is off by default.

On Windows 7 and Vista, ClearType is turned on by default.

You can also try the Microsoft ClearType Tuner

share|improve this answer
    
I checked and cleartype is enabled. –  Laura May 30 '10 at 6:30
    
@Laura - Have you tried to turn ClearType off to see if that's an improvement? –  Nifle May 30 '10 at 9:24
    
@Nifle Yes but it makes it worse. –  Laura May 30 '10 at 14:19
    
Try out the VGA or DVI outputs on another regular monitor, see if the problem is still there. That way you can rule out the PC and video card, and it will narrow the issue down to the monitor and it's setting. –  sunpech May 30 '10 at 14:57

I also experienced jagged text with a Samsung B2230HD. I was able to get decent video as follows:

  • With remote, hit Menu
  • Picture > (hit the right arrow)
  • Backlight 12
  • Brightness 50
  • Sharpness 0 (* important)
  • Color 50
  • Advanced > (a submenu of Picture)
  • Black tone off
  • Color Space auto
  • Edge Ehancement off
  • < to Picture menu
  • Picture Options > (a submenu of Picture)
  • Color tone cool
  • Size Screen Fit (* important; fixes loss of pixels on right edge due to overscan)
  • < to Picture menu
  • return

This is with an HP laptop running ubuntu 11.10, but I expect similar results for other hardware/OSes.

share|improve this answer

I have a Samsung SyncMaster B2330 connected via HDMI. The font issue had been driving me nuts. After fiddling with the controls, I achieved the most impact by changing the "PC/AV Mode" from "AV" to "PC".

Menu > Setup & Reset > PC/AV Mode > PC

share|improve this answer

Try setting the MagicBright setting to Internet or Text.

Also, turn ClearType back on if you left it off and tune it with the online tuner (or the powertoy).

Finally, from the manual for your monitor:

Q: Image is not clear. Picture is blurred.
A: Run Frequency Coarse and Fine tuning.
A: Turn on again after removing all accessories(video extension cable, etc.)
A: Set resolution and frequency to the recommended ranges.
share|improve this answer

Had the same problem - I had used the monitor over DVI for a year or so when I got a new video card and wanted to switch to HDMI. Suddenly text looked like garbage.

The solution - go into "setup" and turn on power-saving. You'll notice the image gets darker, several of the HDMI options will be greyed out, but the text is crystal clear again. Then go in picture settings and adjust the brightness/backlight/contract levels and you'll be set.

share|improve this answer

For my widescreen 23" LG monitor, the solution was to disable the «Super Resolution+» feature in monitor's settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.