Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Windows 7 almost always restarts when I keep it idle for ~20-30mins. It happened randomly before, but lately, if I leave the computer I can be sure it's gonna restart after those 30mins. It never happens when I play games or work tho, just when it's idle.

It's a fresh install of Windows 7 64bit. I had also problems while installing it, it always crashed while finalizing the install and I had to reinstall again. Eventually it installed on 3rd or 4th try after I deleted all of my partitions and added them again.

I thought it might have been a hardware problem, but temperatures seem to be okay and I have no idea how to track what might have been causing it.

Any ideas?

I'm running Windows 7 64bit on:

  • Gigabyte EX58-UD4P
  • Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz
  • NVIDIA GeForce GTX 260
  • 6GB of DDR3 1066Mhz RAM

I have a very bad feeling it might be something with HDD and its compatibility with Windows 7 as I haven't had those problems for 1 year while I had Vista.


I checked Event Viewer critical errors from this night. PC restarted first time at 11:12pm, then at 3:06am and since then every ~20min until I came back to it.

Error message is:

The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

Source: Kernel-Power

share|improve this question
+1 I had the same problem. Never found a solution, gave it away to a friend who runs SUSE on it and he has no problems. But I think he also swapped/replaced some parts. – Nifle May 30 '10 at 11:17
I have the same problem. No Power management settings on, and it still restarts about 30mins after being idle... odd. – rFactor Aug 13 '12 at 15:17
@rFactor it was most likely combination of new GFX and old power supply in my case. I had also booting issues where sometimes Windows restarted during boot and sometimes it did not. It turned out my GFX needed bit more current on +12V rail. – Ondrej Slinták Aug 13 '12 at 16:27
up vote 4 down vote accepted

Check power management. Maybe it dies when it tries to go into sleep or some power management causes this. Try choosing max performance to see if this is the case.

share|improve this answer
Nope, doesn't work. I just cannot replicate it. It's always ~20min even if I have sleep, hibernation etc turned off. I thought it might be something with power supply, but then I don't understand why even the newest games don't cause this. Just when the PC is idle. – Ondrej Slinták May 30 '10 at 13:56
If you set the power to maximum perf, it can't really go into idle. However, you should try burn your stuff with Furmark, Prime95/sp2004 stress test. You'll see which is the faulty. (Only play with this if your stuff is still got a warranty.) | By the way. What about your power supply? – Shiki May 30 '10 at 14:04
Both Furmark and Prime95 haven't found any problems. How can check whether is my power supply okay or not? Wouldn't like the buy a new one and find out the problem was somewhere else. – Ondrej Slinták May 30 '10 at 18:52
The easiest way only if you try a different PSU. Just cable to your PC from the other computer case, or simply replace it for a time of being. For trying it out. Ask a friend. :) – Shiki May 31 '10 at 10:55

I think i found out what it is. Try going to power management and click on troubleshoot. If you dont have a screen saver selected, then when the power management option kicks in after 20-30 minutes being idle, it restarts. The torubleshooter will apply the screen saver. Should correct the issue.

share|improve this answer

Mobo: Gigabyte Z68XP-UD3

GPU: Nvidia GeForce GTX550 Ti

I just recently had the same issue, 64bit Windows 7, when running idle, every single time it would crash/restart. No BSOD. As long as things were running and I was working on the computer (word, games, youtube, movies) there would be no crash, but the second it went idle, it would crash/restart.

I wasted a bunch of time trying to pinpoint the problem, (from the beginning I speculated drivers). 19 hours Memtest= 0 errors.

I immediately gave up and just did a fresh install of windows 7. I updated the BIOS (ver F9b). And then for my video card, I downloaded drivers straight from the net this time.

I had heard one post claiming the drivers off of the original CD were causing him problems, he said "DON'T INSTALL DRIVERS OFF THE CD THAT CAME WITH THE CARD".

No problems since. I sure hope this doesn't happen again.

share|improve this answer

I had the same problem, and I fixed it by performing the following steps:

  1. Go to "Control Panel" → "Power Options".
  2. On the left hand side of the screen it should say "Change when the computer sleeps". Click it.
  3. Click "Change advanced power settings".  A small "Power Options" window will pop up.
  4. Expand the "Hard disk" section by clicking on the + to the left.  Similarly, expand "Turn off hard disk after".
  5. Set the "On battery" and "Plugged in" values to "Never" (by clicking on the value and then clicking on the down arrow repeatedly).
share|improve this answer

I have the same exact problem on a Windows 7 VM.

It only reboots when I'm not using it!

The VM is configured not to invoke any screen saver, but it's exactly 20 minutes.

Here's some commands to see what's up:

1) Run powercfg -list to show what power scheme is active. Copy the GUID of the active scheme (marked with a start)

2) Run powercfg -query to show you detailed power settings. One of them is a problem...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .