Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a Windows XP Pro SP3 machine one network drive refuses to show up in My Computer or Explorer. The missing drive letter is G: if that matters. Other mappings work fine. Other profiles one the same machine have no problem seeing G: I can access the G: just fine typing it into the address bar or in CMD shell.

I've used TweakUI to toggle hide/show G: with no difference. TweakUI says G: should be visible. I've logged off, on between toggles to make sure the settings are taking effect. I've looked at reg key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] and made sure it's zero'd. ref

We've limped along with this broken setup for some time, just working around it, but some applications do not allow typing in a path when choosing a place to save files and it's reached the point where it's intolerable.

So, anyone have any idea why XP won't show this drive letter? Or how to fix it?

share|improve this question
    
have you checked with Disk Management or diskpart.exe to see if there's some leftover mapping that's causing G: to be hidden? (eg, to a thumbdrive or other device that may not be physically present.) see if this related question gives you any hints. also, does it work properly if you map the network share to some other drive letter? –  quack quixote May 30 '10 at 20:12
    
Disk Management shows nothing for G: (but doesn't it only show connected devices anyway?). I'll have a look at diskpart.exe. Thanks for the link, it's definitely a problem I have at work, but not (obviously) applicable here. –  matt wilkie Jun 1 '10 at 13:26
add comment

5 Answers

I had the same issue on Win7. At some point of excessive "try and error research" I recognized that when I started the command line as Administrator I couldn't see my mapped drive. When I started the command line as the user who mapped the drive... bingo there it was.

That went so far that I could connect a network share on say z: for one user and some other share on z: for another user....

I didn't know that mapping network drives was a user specific thing to do... I'll do some more research on this and post it here, if I can come up with some explanations.

share|improve this answer
1  
Yes mapped drives have always been user specific. Until Win7/Vista it wasn't possible to act as Administrator in addition to the logged in user (excepting the runas command, but that's more limited). –  matt wilkie Dec 21 '10 at 18:55
add comment

Was trying to figure out the same thing only to discover later that (in my case) it was just hiding under the CD/DVD physical drive. Since I couldn't change the drive in command prompt (there was no CD inside the drive) and since the disk manager doesn't display on top pane the CD drives (it displays at the bottom) I didn't notice that my DVD drive took the missing letter. Changed, problem solved (for me) HTH

share|improve this answer
add comment

If it's related to an old USB device, you should see something in USBDeview - http://www.nirsoft.net/utils/usb_devices_view.html - which shows disconnected devices as well as connected ones, and shows drive letters too.

share|improve this answer
    
Thanks for the tool suggestion. Nirsoft has great stuff! Unfortunately it doesn't solve this particular problem. –  matt wilkie Nov 4 '10 at 21:02
add comment

There is a subtle difference between XP and 7. In XP you are either administrator or you aren't. Only one logged on session exists. Looking at the command prompt should show the same as looking at what Explorer says (although it doesn't as I currently experience. Also with drive G:)

Win 7 is different. Even if you are member of the Administrators group, you have no Admin token during normal work. If you start a process with "Run as Administrator" you actually start a NEW session with the complete token set. If you now check in the command prompt, one without run as and the other one with run as, these are actually two DIFFERENT sessions. It is therefore "OK" to see different results.

See here how to get it working anyway (this is a security risk as it allows direct communication between privileged and non-privileged sessions): http://support.microsoft.com/kb/937624/en-us

share|improve this answer
add comment

9 times out of 10, a reboot up will fix this, but I have had a 100 percent success rate, when I pull out the ethernet cable from the PC, then shut down. Then plug the ethernet cable back into the PC, and boot it back up. (Viola, there it is) I have found that little problems like this are usually (not always) caused when the network has tried to push an update of some type while a user is either still logged in or has rebooted during an update push. You can also open cmd prompt and type "net use /delete" (without the quotes), then manually remap the drive to fix it temporarily.

Hope that helps.

share|improve this answer
1  
So many problems and assumptions with this post... What updates are you talking about? Are you aware they only come out on patch tuesday? Why would he be getting an update "pushed" out during the day? Also you need a letter with the net use command otherwise it will unmap all drives. Lastly your pull out the Ethernet cable then shut down scenario is purely andecdotal. Why would windows care about the state of the adapter while it's off? How would it even know? –  Kyle Apr 24 '12 at 16:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.