Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Terminal.app, and I'd like to use emacs running inside - either locally, or after sshing to remote server. Problem is, I can't get working Meta modifier.

Namely, if I enable 'Use option as meta key', Option key works like proper Meta, but I lose ability to enter Polish diacritics (ąęłóśźńżć), that are entered with right Option.

If I disable 'Use option as meta key', my Meta is gone, but I can again use Polish characters. In this state they appear only with right Option modifier, so I guess it's Terminal.app's fault that it doesn't make a difference between left and right Option key, when the relevant preference is selected.

What are my options then? Is there a good solution for my problem? I can always use ESC as a poor man's Meta replacement, but I don't like that idea.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

OK, I got annoyed enough and wrote an iTerm patch, that allows me to do what I want: left Option is Meta, right Option is national characters modifier. You can find the patch, binary and the rest of the story here

share|improve this answer
    
Your link doesn’t appear to work any more. :( –  Ollie Saunders Aug 17 '11 at 23:02
    
Ah, I see this feature is in the latest version. Shweeet. :) –  Ollie Saunders Aug 17 '11 at 23:05
add comment

You might be better remapping the ever-useless capslock to meta? Fairly standard redo for *nix versions of emacs, but you will have to do an iTerm patch, probably.

share|improve this answer
1  
Capslock is already Control :) –  yacoob Jun 14 '10 at 9:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.