Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't get DHCP to assign IP to my wireless devices.

My network config is as follows:

  1. Nanostation5
  2. Linksys WRT350N, which is connected with Nanostation via its INTERNET port.

Nanostation:

LAN IP Address: 192.168.1.20
WLAN IP Address: 192.168.0.79
Network Mode: Router and is getting its IP via DHCP from my ISP
Netmask: 255.255.255.0
Gateway IP: 192.168.1.1

LAN Network settings:
IP Address: 192.168.1.20
Netmask: 255.255.255.0
Enable NAT: YES
ENABLE DHCP Server: YES
Range 192.168.1.100 ~ 250
Netmask: 255.255.255.0
Enable DNS Proxy: YES

Linksys:

Internet Connection Type: DHCP
Router IP: 192.168.2.1
Subnet Mask: 255.255.255.0
DHCP: Enabled
Start IP: 192.168.2.100 ~ 120

Advanced Routing:
NAT: Enabled

What I can do is connecting manually with this config:

IP: 192.168.2.101
Subnet Mask: 255.255.255.0
Router: 192.168.2.1

DNS: 192.168.1.20
Search domains: WRT350N

I want to be able to connect to both routers independently(now its 192.168.1.20 for Nanostation, and 192.168.2.1 for Linksys) and connect any wireless device using DHCP.

What should be IP ranges, masks, etc. on both devices?

share|improve this question
add comment

3 Answers

I do not understand what it is you are trying to achieve. What do you want to accomplish and why do think using two different subnets on home routers will do it?

The normal way multiple (home) routers are interconnected is to disable DHCP on all but one of them and (2) to put them all on the same subnet. Why? So that you won't have the conflict of both routers attempting to assign a different IP address for their subnet at the same time.

The other potential problem I see is that you have NAT enabled on both boxes. Why? Only 1 of the routers should be connected to the Internet and that is the one that needs to have NAT enabled. The other is basically just functioning as a switch and possible as a Wireless Access Point (WAP). You don't want to be NATing on top of NAT.

Maybe the info in this article will be of use to you.


Some additional thoughts:

I want to be able to connect to both routers independently

I wasn't clear on what you meant by that when I wrote the above. Looking at it again I'm wondering if you meant that you want to be able to connect wirelessly via either router. In other words, add one of the routers to the network of the other router as a another Wireless Access Point in the same wireless network.

If that's what you're trying to do then perhaps this article on how to add another WAP will help.

FWIW, the idea behind subnets is to provide a simple way to route packets. When using the Internet Protocol (IP), the first thing a device must do before sending a packet is decide whether or not the destination computer is on the same physical network or on a different/external network. In other words, can the packet be sent directly to the other computer on the local ethernet or does it need to be sent to a router to be resent to a physically external/different network.

If the destination IP is on the same subnet as the sending device, then the sender looks up the ethernet MAC address of the destination and then sends the IP packet directly on the local ethernet. If the destination IP is not in the same subnet as the sender, then the packet is sent to the router which tries to forward it to the destination network.

The home networks I'm familiar with are logically one physical ethernet network. All the devices should be able to talk directly to each other. So all the devices on a home network should be placed within the same subnetwork.

share|improve this answer
add comment

If you have multiple DHCP servers on the same network, they will "fight" over assigned IP addresses.

Here's a brief explanation of how DHCP works:

When your computer sends out a request for a DHCP lease, it gets sent to the special broadcast IP, 0.0.0.0, which means that it is sent to every computer on the network, including both routers. If both routers receive this message, then both will send another broadcasted message to ask each computer on the local network whether they have any claim to the IP address it chooses. If nobody responds, DHCP sends a response back to the computer that requested an IP that says, essentially "Hi. I'm your friendly DHCP server. It's okay to use 192.168.0.x. By the way, here's the size of this network, and here are the IP addresses of the DNS servers we use, and the IP of the router you should send packets to to route them to a network that's larger than this one." If the computer receives more than one packet with this information in it, it will sometimes use the first one, and sometimes use the last one it received. You never know.

Okay, with that out of the way, what you should do is only allow ONE of the routers to act as a DHCP server, and, for network uniformity, use a range of IP addresses that fit in the same IP mask.

The IP mask you have configured, 255.255.255.0 in the subnet 192.168.1.0 will only cover IP addresses from 192.168.1.0 through 192.168.1.255. The IP addresses of the other router is 192.168.2.1, which does not fall in that range. I would recommend increasing the size of the network mask to a class b network, or 255.255.0.0. Either that, or you could configure your other router to have an IP address of 192.168.1.100 or something.

share|improve this answer
add comment

I don't know anything about the Nanostation, but here are a couple of suggestions.
(My home network is similar - I have a wireless router provided by my ISP, and a linksys.)

I looks like you have 2 different subnets in play - 192.168.2.x for the linksys, and 192.168.1.x for the Nanostation. I'd suggest starting by hard-coding the IP for the linksys to be something like 192.168.1.3, and then restricting the start IPs for each box so that they don't conflict.

If that doesn't work, or you need more wireless connections than that provides, you should be able to configure the linksys so that its WAN connection is .1.3 (for example) but its IP is .2.1 and it serves DHCP for the whole .2.x subnet.

One final problem you may have to deal with is the DNS settings for the network coming down from your ISP. I fixed that problem by simply using openDNS and hard-coding that into each router. (You could also use googles DNS servers if you prefer).

share|improve this answer
2  
Also, NAT should be only enabled on the router connected to the Internet. –  harrymc May 31 '10 at 17:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.