Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The system is a PowerPC Mac Mini running MacOS Tiger 10.4.11.

When I login (I'm the admin), everything seems fine - until about 10-15 minutes later. Then the system goes into sleep mode. Each time I try to wake the system up - I can barely log in before it goes to sleep again. Sometimes I don't have enough time to enter my password (from the screen saver).

If I shut down and restart, then I have that 10-15 mins again - until it again goes to sleep.

I checked the settings in the Displays and Energy System Prefs. I looked at Accounts and at Screen Saver System Prefs; no times seemed to be present. I've already reset the PROM and other things (as part of an earlier problem shooting session).

If I don't log in at the desktop, things seem to be fine. Nothing in .profile, /etc/profile, or /etc/bashrc seems to stand out.

Right now, the system is hardly usable; can someone help? Many thanks...

EDIT: Thanks for the migration. I only just found out about superuser.com; fantastic!

PS. I should mention that the sleep occurs even if Caffeine is toggled to "no sleep", and even if Jiggler is running (both programs set to keep the system from sleeping...)

share|improve this question

migrated from serverfault.com Jun 1 '10 at 3:21

This question came from our site for system and network administrators.

Do you happen to be using an aftermarket keyboard with a sleep shortcut key on it? I had a wireless one that was busted and would randomly sleep the computer when I typed the letter "p"

share|improve this answer
    
I'm using a Microsoft Natural keyboard via a USB-PS2 adapter; I'll switch back to the USB-based Macally keyboard I had been using and see what happens. – Mei Jun 1 '10 at 20:13

These symptoms sound like System Management Controller corruption.

Follow these instructions to reset it.

Oh, never mind, i missed your specs. PowerPC eh?

Well I'll leave this answer here in case Intel mac owners find a similar problem. :)

In your case, you need to Reset the PMU. You said you reset the PROM. (Did you mean PRAM?) This procedure also does that, I don't know if you've tried it.

Instructions here.

share|improve this answer
    
Tried it again, just to make sure. Don't know if this will make a difference - especially since it appears to only happen when the admin (me) is logged in... – Mei Jun 1 '10 at 20:12
    
Have you checked the Console logs? Might have a clue there what process is causing it to go to sleep… – ghoppe Jun 2 '10 at 5:56
    
I looked previously but will again. The system mostly works now (with different keyboard) but it was still going to sleep as I recall. It did have some disk issues that needed a fsck; I wonder if that had anything to do with it. The system is also prone to filling its system disk... Will look at it again. – Mei Jun 20 '10 at 2:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .