Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to compile KDE from sources and I get this error when trying to make kdelibs:

Could NOT find Phonon: Found version "4.3.1", but required is at least "4.3.80"

I am running Kubuntu karmic ... and I have the latest phonon dev files. How can I upgrade it to the version that kdelibs needs?

share|improve this question
add comment

1 Answer

Get phonon from Gitorious (http://gitorious.org/phonon), and compile it and install the same way you'd do with other KDE SC modules.

Mind that if you don't install it with the same prefix as the system's is, you'll have to tinker with cmake to tell it where the new phonon is.

p.s. It would be a good thing first to uninstall the old libphonon and install the new one by checkinstall so that the apt system knows that phonon is installed

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.