Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I found a similar question but it has no satisfactory answers.
I have a D-LINK 2540U DSL router. It has a basic port forwarding(under DNS -> Virtual Servers) configuration in the administration panel where you specify: external port range, protocol, internal port range, server IP address and it is supposed to forward that port to that IP address.

When I first set it up for a Real VNC connection it worked fine, just as I expected. Then I added a DynDNS configuration entry in the router's 'Dynamic DNS' section and added an additional SSH (22) forwarding rule. The SSH forwarding also worked fine (now with the dynamic hostname, but I suppose it doesn't make any difference as far as SSH is concerned).

Then I removed the SSH rule and after that the VNC forwarding stopped working with the VNC client failing to connect (I have tried to connect with telnet and it also failed to connect, so it wasn't a VNC problem).
After adding a rule for port 80 it turned out it would forward on port 80 though not to the specified server IP but to the modem itself. At least it is what it looks like, because it gives me the administration panel when I connect to my external IP (both using a browser and plain telnet in which case I can see that it is mini_hhtpd sitting on the port, which is obviously the modem's administration panel).

Have anybody encountered a similar problem with port forwarding?

I have tried to do a reset through the administration panel and to restore a backup of the settings made before I started playing with port forwarding, but it didn't help.

Should I do a 'hard' reset with the button on the modem? Is it any different from the administration panel's reset (Restore default)?

Edit: The problem was not in the router itself, but in how I tested the forwarding. When I tested from the same internet connection it didn't work (I'm not sure if it is possible at all when accessing from the same connection) and when I tested from work it didn't work because the port is blocked in the corporate firewall. The forwarding is working from other connections.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Nothing can forward TO the router, because the router forwards traffic from itself to somewhere else. Traffic comes in and hits the router, it is dropped unless the router has an open port (usually port 80 for config and stuff) or there is a forwarding rule.

The most likely reason why your forwarding stopped working is because your IP address changed. Do you have DHCP enabled or are you using static IP addresses which you, yourself assigned. You also want to look at any security programs you installed recently such as firewalls, etc.

Lastly telnet wouldn't connect unless you had a specific forwarding rule for that port (unless you specified the same port your VNC server was on). You would also have to have a to be running a telnet server.

share|improve this answer
    
Indeed, the 80th port has the administration panel on the external IP even without the forwarding rule and when I'm adding the rule for port 80 it says it has to move the administration panel to port 8080 because of this, but it doesn't appear to listen on port 8080 after adding the rule, the same 80 for the administration panel both from the inside and outside. As to telnet I specified the port of interest to the telnet, not its default port. –  axk Jun 1 '10 at 19:58
    
I have static IPs everywhere, so this can't be DHCP I think. –  axk Jun 1 '10 at 20:00
    
After you switch the router to port 8080 you may have to reboot the http server, turn the router off and on again then it should work on 8080. Did you check if you were using DHCP? If you are, then check that you still have the same IP address lease as specified in the forwarding map. You can do this by typing IP config in a command line on windows. –  Daisetsu Jun 1 '10 at 20:02
    
Rebooting the modem didn't help, I still can't connect to 8080 both from the outside and inside. –  axk Jun 1 '10 at 20:22
1  
Then all I can suggest is that something is configured wrong or changed since you had VNC working. There's no reasons why a system working fine, if left alone will just inexplicably die. I were you I would suggest checking each link at a time, such as checking if you can connect to the VNC server from within your own network, then check the forwarding, if that works, check what your ISP is blocking. –  Daisetsu Jun 1 '10 at 21:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.