Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Lately Windows 7 has been telling me that I need to check disk D: for consistency. This happens more than 50% of the time when booting up.

The first time, I didn't touch anything so that it would go ahead and do its scan. It didn't seem to do anything - just booted straight into Windows. The second time I tried to skip it by pressing any key. It ignored all of my keystrokes and still counted down to 0 (then skipped the disk check).

Sometimes, it gets down to 0 but then just hangs... no indication that anything is going on.

This is happening on a < 3 month old laptop. C: and D: are on the same physical disk - just two partitions. I never get any notification that C: needs to be checked for consistency.

It's a ~300GB HD. C: has 60gb (32gb free) and D: has ~240GB (122gb free).

What could be causing this to keep coming up? What can I do to fix it?

Thanks!

share|improve this question
1  
Have you tried manually checking the disk? –  Hello71 Jun 1 '10 at 22:54
    
That did the trick, but I can't upvote you or accept your answer because you didn't post your suggestion as an answer. Please post your suggestion as an answer and I will do so. –  Michael Moussa Jun 4 '10 at 1:25

4 Answers 4

up vote 1 down vote accepted

Be careful and do a full disk backup as soon as you can.

I've encountered problems with chkdsk in the past that resulted in the KSOD (where you boot to a black screen with a cursor arrow but nothing else). Immediately before this, chkdsk found errors and then went through a process of resetting the security descriptors for every file on your hard drive.

This happened to me three times, and every time the only solution for me was to reinstall the OS and all the programs.

Anyway, chkdsk is serious business, so please make sure you have a backup.

Not sure what could cause it. Perhaps a bad delayed write where your hard drive shut down before all the data could be committed to disk. Or perhaps a bad sector or a bad bump on the drive.

Another possibility - I don't know if it affects Win7. Vista defaults to hybrid sleep, which is the worst idea in the world for a laptop, IMHO.

Basically, when you put your computer to hybrid sleep, it first sleeps for a set time before then going into hibernation. The rationale is that sleep constantly draws power while hibernation does not, so it makes sense to sleep first so you can wake it quickly, and then transition to hibernation later to save power.

But if you're like me, the reason you're putting your computer to sleep is because you want to move it around and go places. Having it try to switch from sleep to hibernation and save system state to your HD while you are bumping around with your laptop in your knapsack is a bad idea IMHO.

Check to see that this is not enabled.

share|improve this answer

In the file manager, when you right click on your D drive, click properties. On one of the tabs should be an option to check the disk. Go ahead and schedule a chkdk from there. If you have a bartPE or vistaPE boot CD's you can do a chkdsk d: /f where d is whatever drive your d drive happens to mount as under the live cd.

I think using a live windows CD is your best bet. It would also be interesting to see what the S.M.A.R.T status of your hard drive is... even though its supposed to be new.

To check the SMART status, you can install HDTune. On the health tab it has all the status information. There is a button to copy the contents as text and you can paste it in if you want.

share|improve this answer

I experience it before. From what i realize is that this happen when i was handling my laptop roughly(running with it) when I am outdoor. And when i reach home, it always require me to check for my drives. But when i leave it at home and use it few times (booting it up and down) there is no issue.

If you want to disable the chk disk try this: disable chk disk

share|improve this answer

Can you access Windows? If so, then follow the instructions in the other answers.

If not, then shut down your computer. Now turn it back on and after it shows the boot screen, press F8. Try selecting "Last good known configuration". If that doesn't do it, then go back to F8 and select "Safe mode". Wait for it to load, then log on, go to Computer and turn off the option that runs chkdsk. Or if that doesn't work then delete the last update you downloaded and reboot your computer. I that still doesn't work, take it to the pros and get it fixed.

If you can't get into safe mode at all then either take it to pros or let chkdsk run through completely. But be warned - chkdsk is serious business so be careful.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.