Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

PS Command output is truncated in Solaris. I tried the below command after g Googling out. It doesn't work. Not sure what needs to be done

/usr/ucb/ps awwx 
share|improve this question

migrated from stackoverflow.com Jun 3 '10 at 0:52

This question came from our site for professional and enthusiast programmers.

    
What do you mean "truncated"? Have you read the manual? –  Matthew Flaschen Jun 3 '10 at 0:41
    
"It doesn't work" doesn't work. –  Dennis Williamson Jun 3 '10 at 2:44

1 Answer 1

up vote 7 down vote accepted

Solaris 10 and later no longer make /usr/ucb/ps setuid-root by default, and you need root privileges to poke into the address space of other users processes to get the full set of arguments.

Run it as root or the process owner to see more than 80 characters of the command line.

On Solaris 11, if you use options without a dash (like /usr/bin/ps auxwww) they will be treated as UCB style options, and the output will show extra long lines, even when you are NOT running as root. This is not well publicized.

For further reference:

share|improve this answer
    
Thanks a lot for the info –  user38993 Jun 3 '10 at 3:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.