Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set the default location from c:\inetpub\wwwroot to d:\inetpub\wwwroot but when I access my .NET 4.0 site get this error:

Description: An error occurred during the processing of a configuration
file required to service this request. Please review the specific error
details below and modify your configuration file appropriately. 

Parser Error Message: Unrecognized attribute 'targetFramework'. Note
that attribute names are case-sensitive.

Source Error: 

Line 105:            Set explicit="true" to force declaration of all variables.
Line 106:        -->
Line 107:       <compilation debug="true" strict="true" explicit="true" targetFramework="4.0">
Line 108:           <assemblies>
Line 109:               <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

When I try to Manage the Basic Settings on the Site and click the "Test Settings" button, I see that I have a problem under "authorization:"

The server is configured to use pass-through authentication with a 
built-in account to access the specified physical path. However, 
IIS Manager cannot verify whether the built-in account has access. 
Make sure that the application pool identity has Read access to the 
physical path. If this server is joined to a domain, and the application 
pool identity is NetworkService or LocalSystem, verify that 
<domain>\<computer_name>$ has Read access to the physical path. Then 
test these settings again.
  1. Do I need to grant rights to IIS to the new folder? Which user? I thought it was something like IIS_USER or something similar but I cannot determine the correct name of the user.

  2. Also, do I need to set the default version of the framework somewhere at the Default Site level or at the Virtual folder level? How is this done in IIS6? I am used to IIS5 or whatever came with XP Pro.

  3. My original site had a subfolder under wwwroot called "aspnet_client." How was this created? I manually copied it to the corresponding new location. My app was using seperate ASP specific databases for storing session state and role info, if that is relevant.

Thanks

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Given the error message you're seeing, it looks like your site isn't running with .NET 4 (where the targetFramework attribute was introduced). Check the settings for your AppPool and make sure it's set for .NET 4.

share|improve this answer
add comment

Inspect the permissions on the original IIS web site root folder and you will see that the user group IIS_IUSRS is given all but Modify and Full Control rights. You'll see also that "Trusted Installer" is given access. I have no clue how to add this dude to the new folder rights.

To set the .NET version for the site or the web site, select the folder, click Advance Setting, click on App Pool and then select the appropriate .NET version.

share|improve this answer
    
Chad, you rock dude. –  Chad Jun 3 '10 at 4:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.