Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 x64 on an iMac (via BootCamp) with the button-less Magic Mouse that comes with the iMac. I would like to disable the horizontal scrolling that happens when you move slightly the finger horizontally while doing a vertical scrolling.

In the Control Panel, Mouse section, Wheel tab, Horizontal Scrolling section, the minimum value that you can enter is 1, not 0. Is there a way (in the Registry) to disable horizontal scrolling using the mouse wheel? Or to set that value to 0 to see if it does the trick?

Notice that this is a Windows specific question, not Mac OSX or Apple or Magic Mouse question, it can apply to any mouse in Windows whose wheel supports horizontal scrolling apart from vertical scrolling.

share|improve this question

5 Answers 5

Maybe AutoHotkey could be setup to catch (and ignore) mouse horizontal scrolling?

Check out WheelLeft and WheelRight: http://www.autohotkey.com/docs/Hotkeys.htm

share|improve this answer
    
I tried it but it doesn't work when the active window has an horizontal scrollbar, it seems that the window has priority handling the mouse wheel event so AutoHotKey can't handle it to ignore it. Any other ideas? –  Carlos Jun 5 '10 at 11:47
    
I have a mouse which is (apparently broken and) constantly sending WheelRight, this answer saved my life! –  Vargas Sep 18 '11 at 21:31

I'd just like to add that Matthew's solution worked for me for a related problem. I was using Chrome on Windows 7, and when I tried to middle click a bookmark that was in a folder in the bookmarks bar, it would frequently close the folder and send the middle click through to the bottom of the page. It turns out it was registering the side scroll clicks of my mouse (which I never use) and dismissing the active folder dropdown.

I tried to vote the answers up, but apparently I have no reputation... Anyway, if google picks this up and I can help solve someone else's problem, that'll be enough for me!

share|improve this answer

I use MagicMouse on iMac with Windows 7 running (installed through BootCamp). Got sick of annoying horizontal scrolling. The solution described above has helped me to disable it. Here is what I've done in steps:
1) go to http://www.autohotkey.com/ and download an app (a script editor).
2) Install and run the program - please note that it will not open as it runs in the background
3) Rightclick on the desktop -> choose "New" -> "AutoHotkey Script" (a new script file will be created on the desktop) -> name it as you wish (e.g. "Mouse_HScroll")
4) Rightclick on the file you've just created and choose "Edit Script" from the menu.
5) Add these three lines below existing text in the file:
WheelLeft::return
WheelRight::return
#MaxHotkeysPerInterval 5000
6) Save file
7) Run "Convert .ahk to .exe" program from the package installed earlier and browse the file you've just created, hit ">Convert<" -> .exe file should be created. Run this file -> the scrolling should be disabled now.
7) You may wish to move this file to Start/"Autorun" folder, so it would be launched automatically each time you reboot your Mac/PC.

Hope this helps! Good Luck

share|improve this answer

When you tried to override the side to side movement of the mouse with AutoHotKey, what did you use? If you wrote

WheelLeft::return

WheelRight::return

it should have globally disabled horizontal scrolling. Anyhow, I guess my question is, what did you say in AutoHotKey?

share|improve this answer

I prevoiusly had such a problem but not on iMac and on a x86 and with the following trick it solved.

The registry values that are related to this are in HKEY_CURRENT_USER\Control Panel\Desktop

Here there are two String Values: WheelScrollLines for vertical scrolling and WheelScrollChars for horizontal scrolling.

You can set the value of them to 0 to disable theme.

A log off may be needed.

But notice that as I experienced if you go to the Control Panel > Mouse section > Wheel tab they will be enabled again, even without confirming the window.

I know that this isn't standard but worked for me and hope help you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.