Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Snow Leopard, and I'm used to activate / deactivate WiFi like 20 times per day. The reason is that WiFi stops working properly after a few minutes of use. So every time I try to surf, I must stop/reactivate it first.

But now, suddenly I have to enter my user password every time I want to do it. It's so annoying!

The dialogue details say:

Right: com.apple.airport.power
Program: SystemUIServer

What can I do that the Mac won't ask me for the password every time? It's hard enough that I have to stop/reactivate WiFi all the time (hardware bug). I have a admin account with full rights.

share|improve this question
    
Why not also debug the underlying problem causing your WiFi to stop working periodically? –  Spiff Jun 3 '10 at 16:03

4 Answers 4

up vote 3 down vote accepted

It is possible that your network is no longer defined as preferred.

See this article: How can I have my Mac auto-connect to my wifi network?

share|improve this answer

I've had a similar problem, and solved it by opening /Applications/Utilities/Keychain and deleting the associated password to the wi-fi spot. Quit Keychain, and then when you connect to the wi-fi spot enter the password (hopefully for the last time)

If this doesn't seem to fix it, try repairing your permissions as it might flush out why it doesn't think you have full admin rights. /Applications/Utilities/Disk Utility --> 'repair permissions'

share|improve this answer

It's a choice in the Advanced menu of Airport (in Network). Go to the bottom of the first tab (airport) in Advanced and untick that option.

share|improve this answer

Well, this is very late but I was hitting the same problem and finally found the solution in 10.6.

The problem resides in the file

/Library/Preferences/SystemConfiguration/preferences.plist

If you open it and search deep inside, you will find a set of keys that say:

<key>RequireAdmin</key>
<true/>
<key>RequireAdminIBSS</key>
<false/>
<key>RequireAdminNetworkChange</key>
<false/>
<key>RequireAdminPowerToggle</key>
<false/>

This is the translation of the network preferences pane in XML. In the System Preferences, I explicitly said I did not want to be prompted for a password when changing Airport status (on/off) or switching networks (SSID's). All these options are translated into "false" in this file.

There is however ONE key that I could not find reflected in the System Preferences Network pane... the simple short "RequireAdmin". This one here is set to "true" and there is no graphical element in the System Prefs to change it (not that I found at least). When that value is set to true (which is the case), SystemUIPreferences will prompt you for a password each time you do just anything to Airport via the system status bar.

We can fix that. The trick is to modify that value and then restart the SystemUIServer.

Operation 1: modify the preference file

open a terminal and edit the file with

yourname-mac:~ yourname$ sudo vi
/Library/Preferences/SystemConfiguration/preferences.plist

Then search for RequireAdmin. Change the value of that key from "true" to "false". The file will now contain

<key>RequireAdmin</key>
<false/>

Save the file and exit the editor.

Operation 2: restart SystemUIServer

From the terminal, search for the process SystemUIServer:

yourname-mac:~ yourname$ ps ax | grep SystemUIServer
387   ??  S      0:02.66 /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer
96101 s000  R+     0:00.00 grep SystemUIServer

The first entry is the right one -- the process SystemUIServer is started early on an will usually have a small process ID (PID). Here it is 387 but the numnber will likely be different on your system.

It is now time to kill the process -- MacOS will restart it for you and the new process will take your changes into account. Let's kill it now:

yourname-mac:~ yourname$ kill -9 387

The system menu applications flicker then re-appear. Try changing the Aiport status or switching network now... no password!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.