Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I look at a story on Slashdot, I see a side-bar that sits constantly in the upper-left corner. Every time I open a story, I have to click on the "slash" sign in its upper-right corner.

enter image description here

How can I disable it, so it will always have css position absolute, relative or static? Is there an option for it? Because I find it is slowing my browser down when I am scrolling the page.

I am a registered Slashdot user, logged in.

share|improve this question
    
I'm sure I'm being dumb, but I can't recreate - could you post a link? – Andy Jun 3 '10 at 18:24
    
That is a Screenshot taken from this URL: tech.slashdot.org/story/10/06/02/2317241/… The title at the top is the title of my browser's tab. The box below it is always fixed on the page and it is quite annoying. – Tom Jun 3 '10 at 20:06
    
can you write greasemonkey scripts? – Andy Jun 4 '10 at 12:21
    
@Andy I had hoped to find a configuration setting. – Tom Jun 5 '10 at 18:17
    
Understood, don't know if it's possible, not sure how it would be presented if it was. Good luck! – Andy Jun 5 '10 at 19:39
up vote -2 down vote accepted

If you are willing to use the old Slashdot discussion style, you can disable dynamic discussions to remove this. Follow these steps to disable dynamic discussions:

  1. Login
  2. Click on Help & Preferences
  3. Under Discussions click on Viewing
  4. Uncheck Enable Dynamic Discussions
  5. Click Save
share|improve this answer
1  
This does solve the problem, but it disables the whole JavaScript. I only want that box to be gone when I scroll down. – Tom Jun 3 '10 at 20:47
    
@Tom: That is correct. Personally I prefer the old Slashdot comment style but I am used to it because that's how Slashdot has always been in my mind (due to nostalgia). I know of no other way to disable the floating box that follows you down the page via Slashdot's preferences. If you want a solution that specifically solves this problem you will probably have to use a custom browser extension (you'll need to tell us your browser for this). – Trey Hunner Jun 4 '10 at 1:26

Install this addon (if you haven't already) and this user script. This appears to disable position: fixed everywhere; if for some bizzare reason that is a problem for you, edit the @include line to taste. You may need to add ,null to the window.getComputedStyle call or ,false to the window.addEventListener call (or other adjustments); if so, you probably won't get get any notification that you need to do so, just the script silently failing.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .