Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Once upon a time when I started sqlite from the command line I could using the tabbing autocomplete to enter the database name. This has not worked for a while now. Any suggestions on how to do this? (Possibly specifically for files with a .db suffix.)

share|improve this question
1  
Are you using Bash (or zsh)? Do you have bash-completion installed and activated? – Dennis Williamson Jun 3 '10 at 19:51
1  
bash. bash-completion is enabled - just not working for sqlite. – Donnied Jun 3 '10 at 21:54

From: http://www.linux.com/archive/feed/54005

complete -G "*.db" sqlite would associate .db files with sqlite.

For permanent associations, you need to add the command to one of the bash startup scripts, such as ~/.bashrc.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .