Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run Windows 7 64bit with dual monitors at work.

If i connect from home using remote desktop, the next morning i cannot wake up the monitors.

The computer seems to be fine (i can connect again from another pc using remote desktop) but monitor will stay blank.

I've tried unplugging the monitors and reconnecting them but still won't wake up.

The only solution is to restart the machine.

Some specs if it helps.

HP 3000 Pro, Windows 7 Pro 64 bit, ATI Radeon HD 4550, Samsung SyncMaster 2243 x2

share|improve this question
    
I'm not sure if a windows update has fixed this, but i no longer get this issue. –  dev5 Feb 1 '12 at 10:43

4 Answers 4

It's not a fix, but a workaround as I too have the same issue. When this occurs, press the Windows + P key - then left or right arrow, then Enter. Viola!! ; - )

share|improve this answer

I have had a similar problem with Vista on a two monitor system. The fix I found was to ensure that the primary monitor as far as Windows is concerned is the first monitor as far as your graphics cards/drivers are concerned. In my (single card) case I see the problem if I have the VGA output as primary in Windows but not if the DVI output is set as primary. So if the problem you are seeing is the same, try switching which monitor Windows considers to be the primary.

Before discovering the "fix" for my issue I found two workarounds:

  1. The machine was actually OK and the login screen was "displayed" ready to accept input even though the monitor was stuck in power-save (as an extra oddity: the other monitor was not in power save, and the mouse cursor could be seen on it). Logging in by remembering the right keyboard sequence sorted it as Windows seemed to reset the screen resolutions and such during the login process which woke up the other monitor.

  2. The machine would power up both monitors fine from sleep, so if you can safely pause the machine for a short while (i.e. it isn't hosting some SLA backed network service) hit the sleep button and then wake the machine back up. If you have no hardware sleep button on the machine you could sleep it when you are finished with the RDC connection instead of just logging out, or you could send the sleep command from another machine on the network via psshutdown or similar.

share|improve this answer
    
Thank you for the tip about settting "correct" primary display - it seems to work for me. –  Erwin Feb 21 '11 at 8:13

I am having the exact same issue, so there is obviously some issue. Even when I log off instead of simply disconnecting, the issue crops up. I usually end up having to RDP in when I get to work to restart the machine.

share|improve this answer
    
Rather than restarting, tell the machine to sleep. That way you don't loose your current working environment of open documents and such and if your problem is the same one I saw the screens will be fine upon un-sleeping the machine. If the problem is the same as mine, also try the "switching which screen is primary" thing as this may offer a permenant "fix". –  David Spillett Oct 4 '10 at 13:14

I've had the same issue and hunting online gave me few more things to try. So I'm listing all steps here for future visitors:

  1. Upgrade your display driver. Even if you have done it, just go to device manager and attempt another one.
    enter image description here

  2. Turn off power saving for monitors (you can still save power by switching off monitors manually while leaving. enter image description here

  3. Make sure that your primary monitor is your main display enter image description here

  4. Select a notepad or any application and hit Win+left/right arrow few times to move the application to next monitor.

YMMV and you may not have to do all steps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.