Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to boot a multiboot-compliant image file (of mzscheme over OSKit) using GRUB2, but the instructions I have are for GRUB. I can get it to boot, but I'd like to have some command-line arguments passed in. The GRUB instructions say to add them after the line:

kernel= (fd0)/boot/mz.mb.gz

They give further instructions about the --fs flag:

--fs <drive> <partition> : mounts the given partition as the root
 directory. For example, to mount the seventh parition on main disk,
 supply: --fs hda f.

My GRUB2 menu entry looks like this:

menuentry "mzScheme" {
    set root='(hd0,3)'
    multiboot /boot/mz.mb.gz --fs hda c
    boot
}

What am I doing wrong?

share|improve this question

1 Answer 1

Comparing yours to my Ubuntu system's grub.cfg, the only thing that appears to be missing from your entry is a filesystem module insertion. Before setting the root, you may need an insmod declaration, like so:

menuentry "Memory test (memtest86+)" {
        insmod ext2
        set root='(hd0,2)'
        search --no-floppy --fs-uuid --set xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
        linux16 /boot/memtest86+.bin
}

Also note there's no boot declaration at the end.

I'm not familiar with the multiboot declaration offhand, but it seems fairly straightforward. If you're able to boot this from the Grub commandline, are there any other commands you have to give when you do? (Not counting boot of course!)

share|improve this answer
    
I'll try that as soon as I can --- I'm packing for a move tomorrow morning. –  JasonFruit Jun 5 '10 at 2:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.