Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I followed the instructions in How To: Install/Setup SmartSVN in Ubuntu. I followed everything and it didn't start. I also tried to update my JRE:

sudo apt-get install sun-java6-jre sun-java6-plugin 

But it does not work for me, because the terminal complains about package sun-java6-jre not being available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or is only available from another source. Error message:

Package sun-java6-jre has no installation candidate

I did run Synaptic, so I managed to install Java JRE, I think. But I cannot view JRE on Chrome using the test applet Othello.

So I think I did not successfully install JRE hence my Chrome and my SmartSVN are not working as expected.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The Sun Java packages are not available in the default Ubuntu repositories. You need to enable Canonical's partner repositories. After following the below procedure they should be available:

  1. Open System -> Administration -> Software Sources
  2. Switch to the "Other Software" tab.
  3. Enable the repository with this listing:
    http://archive.canonical.com/ubuntu lucid partner
  4. Update your Apt cache; either in Synaptic (press the Reload button), or on the commandline (sudo aptitude update).
  5. Now the packages should be available in Synaptic or via your installation command. You can also use this aptitude variation:
    sudo aptitude install sun-java6-jre sun-java6-plugin
share|improve this answer
    
thanks. at least i got my chrome java applet working. however my smart svn is still not working. any ideas? –  Kim Stacks Jun 4 '10 at 17:02

Get sun-java-jdk by adding a third-party PPA:

sudo add-apt-repository ppa:ferramroberto/java
sudo apt-get update
sudo apt-get install sun-java6-jdk

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.