Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a HTPC running windows 7 64bit, hooked up to a Samsung LCD TV. My problem is different types of video are displaying different black levels on the TV.

When I play a bluray through Arcsoft Total Media Theater I have to set the "HDMI Black Level" to "normal" in the TV picture options menu. When I play recorded TV through WMC I have to set it to "low" otherwise the black colors on the video are washed out and grey.

Is there any way to configure the system so all videos are displayed with the same black level? The hdmi black level setting is deep in Samsung's menus so it's becoming a chore to keep switching it everytime I watch a different type of video.

I'm using an ATI 4670 graphics card with HDMI output going straight to the TV. In the ATI catalyst control center I've got pixel format set to RGB 4:4:4 (Full RGB) since the TV wont allow me to change the HDMI black level if I choose one of the other settings.

share|improve this question
add comment

1 Answer

After seeing similar problems with my Media Center setup I've come to the conclusion that this kind of behaviour is 'just the way it is' with a Media Center. I blame Windows, Media Center and the myriad hardware & drivers that can be involved not really being mature enough as a platform for anyone to completely nail down.

Products have to be rushed to market to maximise returns leading to immature and constantly changing drivers, devices have to comply as best they can with often contradictory PC & AV norms, the HDMI sinks often interpret EDID in novel fashions and the whole thing is lashed together by Windows, which of course is never known for inconsistent behaviour or hidden 'features'!

Sorry, not much of an answer, is it? :)

If it's any consolation I had better success with Nvidia cards rather than ATI.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.