Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am new to ubuntu, starting today.

I am trying to setup cassandra database in desktop version.

I downloaded and extracted files into downloads folder.

Now i want to copy files to /Cassandra folder under root. I don't want it to be in downloads folder.

Problem is through UI i am not able to access cassandra folder. And through terminal i can't access downloads folder.

How to move around files either in terminal or UI without this folder security issues. How does it suppose to be used?

share|improve this question

migrated from serverfault.com Jun 4 '10 at 21:09

This question came from our site for professional system and network administrators.

2  
What happens when you try to access the downloads folder through the terminal? Show exactly the commands you use and the error messages you receive. –  Dennis Williamson Jun 3 '10 at 23:11
    
i can't even go to that folder, using cd command –  mamu Jun 4 '10 at 3:58

3 Answers 3

You're gonna want this in your home directory, not root. Build it from there as a normal user, but if you do a make install, run that as sudo make install instead so that you will install it as user root. Run the following commands in a shell script, or if you want to do it interactively, type each line separately (omitting the first line that begins with the # in it).

#!/bin/bash
sudo mv /root/Cassandra ~/
sudo chown -R `whoami`:`whoami` ~/Cassandra
sudo chmod -R ug+rw ~/Cassandra
share|improve this answer
    
If he does type the hashbang line, it'll just be a comment. :) –  Roger Pate Jun 5 '10 at 8:33
    
meh, true. But better to save a few keystrokes ;) –  Avery Payne Jun 8 '10 at 21:00

You can access anything via a console/terminal. You may have to become root (sudo) to perform file operations on the root file system. (or did you mean /root/Cassandra ?)

share|improve this answer

It looks like you want to access /root/Cassandra. By default /root is not accessable to normal users. Try setting permissions on /root to 711 or 755 (chmod 711 /root). You will also need make the Casandra directory writeable (chgrp users /root/Casasdda; chmod 770 /root/Casandra). The use the default group of the userid your are downloading as. It may be the same as the userid.

share|improve this answer
    
I doubt he wants to install it as /root/Cassandra, I think he meant /Cassandra, i.e. at the root of the fs. If he wants to put it under /root/, which is usually the root user's home directory, then he has a misunderstanding. –  Roger Pate Jun 5 '10 at 8:36
    
If so the comments on changing access to the Casandra directory apply with /root applied. –  BillThor Jun 5 '10 at 19:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.