Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a brand new Dell Studio 1558 just last week. It has windows 7 home premium 64-bit installed on it. My friend who is occupying the adjacent room has a laptop with windows XP. Both of us are connecting to the same wireless router of the hotel. My friend is able to connect to the wireless network without any trouble, but when I try to connect, I get the error "DNS service isn't responding". I get this error when I run the troubleshooting option. I met two more people in the same hotel with win XP laptop and they too dont have any problem. I have gone to possibly all the forums and website but I haven't been able to fix this error :(. I have done all the basic troubleshooting but I have no luck yet. Pls help. Following is one forum where the problem seem to have been trouble shooted but not for all.

http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/eeb84518-903d-46d1-9398-80cf211878d7

Problem Fixed (Added later)

I have fixed this issue myself. I do not know exactly which solution worked because I did a lot of changes to the driver settings. But in summary below is the list of what I did which I think fixed this issue.

1) Put 208.67.220.220 for "Preferred DNS server" and 208.67.222.222 for @alternate DNS server"

2) Disabled 'microsoft virtual wifi miniport adapter'. This was a bit tricky part because by default this adapter is hidden. It has to be made visible from the menu in the device manager.

3) Disabled all other miniport adaptors.

4) Restarted the laptop and bingo!!!

share|improve this question
1  
I suggest that you post your solution as an answer, and accept it, to show that the situation is solved. Edit as well your question to remove the solution from it. –  Gnoupi Jun 9 '10 at 12:57
add comment

3 Answers

Try setting a dns like Google's public DNS:
http://code.google.com/speed/public-dns/

share|improve this answer
    
why would I want to add a public DNS. Can you pls clarify? –  pradeetp Jun 5 '10 at 17:10
    
as suggested by you, I have added one of the public DNS IP address in the IPv4 configuration. Nothing happened. The problem remains the same –  pradeetp Jun 5 '10 at 17:33
    
Try setting the security of the network to "Home", disable all security stuff altogether to give it a try ..and then filter out what casuses it (just the usual approach, sorry) –  Shiki Jun 5 '10 at 17:51
add comment

What DNS server is your laptop configured to use? If you have statically set 192.168.0.1 as the primary DNS and changed networks then you are going to run into problems.

Make sure that IPv4 is set to automatically obtain a DNS server, unless you have been instructed otherwise.

You may want to disable IPv6 as well, since Windows XP doesn't have it by default.

share|improve this answer
add comment
up vote 0 down vote accepted

I have fixed this issue myself. I do not know exactly which solution worked because I did a lot of changes to the driver settings. But in summary below is the list of what I did which I think fixed this issue.

1) Put 208.67.220.220 for "Preferred DNS server" and 208.67.222.222 for @alternate DNS server"

2) Disabled 'microsoft virtual wifi miniport adapter'. This was a bit tricky part because by default this adapter is hidden. It has to be made visible from the menu in the device manager.

3) Disabled all other miniport adaptors.

4) Restarted the laptop and bingo!!!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.