Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 external USB harddrives that are on/active during the boot process. I believe that Windows7 is looking at those drives while booting, which is causes bootup to take longer. Is there a way that I can disable these drives until after the OS has booted to the logon screen?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Another solution:

Quoted: I have received a few questions about this method - no it will not disable mice, or keyboards. It only disables storage devices attached to the USB port. This includes hard drives, flash drives, and any other type of USB storage device. And yes, if the user has administrator access they can reverse the changes.

How it operates is simple, we set a registry key that tells the UsbStor driver not to load on boot:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UsbStor

Start = 4 (Disabled) - Don’t start the driver on boot

Start = 3 (Enabled) - Start the driver on boot

share|improve this answer

You probably have to do this in your BIOS, tell it to not boot from USB devices.

From an Intel site:

Resolving Slow Boot Times

Check the following tips to speed up the boot time of your computer.

  • Set the hard drive as the first boot device in the boot order in the BIOS setup (Boot > Boot Device Priority menu).
  • Enable Intel® Rapid BIOS boot in the BIOS setup (Boot menu).
  • Disable Hard Disk Pre-Delay in the BIOS Setup (Advanced > Drive Configuration menu).
  • Disable system functions and features if you do not need them. Examples include: Legacy USB - this must be enabled if you use a USB keyboard or USB mouse outside the Windows* environment (Advanced > USB Configuration).
  • Unused I/O ports, such as serial, parallel and IEEE-1394 ports (Advanced > Peripheral Configuration menu).
  • Event logging (Advanced > Event Log Configuration menu).
  • To enter BIOS Setup, press the key after the Power-On Self-Test (POST) memory test begins and before the operating system boot begins.

Warning: If any problems occur after making BIOS settings changes (poor performance, intermittent issues, etc.), reset the desktop board to default values:

During boot, enter the BIOS setup by pressing F2. Press F9 to set defaults. Press F10 to Save and Exit. If the system locks or won’t boot after making BIOS settings changes, perform a BIOS recovery as described at Instructions for Recovery BIOS Update.

share|improve this answer

Firstly, we need to prevent USBSTOR from being installed unless the currently logged on user is allowed to use USB storage. We do that by restricting access to USBSTOR.INF and USBSTORE.PNF in a GPO such that PNP can't automatically install the driver. This is possible because when PNP installs a driver, the installation is performed using the priviledges of the currently logged on user. Secondly, we need to make sure that USBSTOR is not started when a USB storage device is plugged in. For that we use Mark's ADM template. The only minor drawback of my solution is that users with access to USB storage need to manually start USBSTOR before connecting USB storage devices.

  1. In Active Directory Users and Computers, open an existing GPO or create a new one and open it. Use the security settings of that GPO to specify which computers it affects.
  2. In that GPO, go to Computer Configuration – Windows Settings – Security Settings – File System and create a new entry (right-click File System and select Add File). Specify the location of USBSTOR.INF (usually SystemRoot%\Inf\USBSTOR.INF)
  3. Change the security settings of the new entry. The security settings that you specify here will be enforced on the USBSTOR.INF of every computer to which the GPO is applied. This process is not additive, which means that the previous security settings of USBSTOR.INF will be overwritten by the ones given in the GPO. It is therefore recommended to grant full control to SYSTEM and local administrators. But unlike in the default security settings of USBSTOR.INF, you should not grant any priviledges to Everybody. You do not need to explicitly deny access – just omit an entry for Everybody. Optionally, you can grant read access to a certain group. Members of this group will be able to use USB storage.
  4. Repeat the above two steps for USBSTOR.PNF.
  5. Download USBSTOR.ADM.
  6. Back in the GPO, right-click Administrative Templates under Computer Configuration and select Add/Remove Templates. Click Add and browse to the location of USBSTOR.ADM. Close the dialog.
  7. You should now have an additional entry called Services and Drivers in Administrative Templates. Click on it. If it is empty, select View from the menu and uncheck Show Policies Only. Click back on Services and Drivers in Administrative Templates. It should now show the USB Storage policy. Double click it, select Enabled and pick Disabled from the Startup Type drop down. Again, the policy must be enabled wheras Startup Type must be Disabled.
  8. Close the dialog as well as the GPO and boot/reboot one of your workstations. Make sure no USB strorage device is connected to that computer. Log on with administrative privileges and check the permissions of USBSTOR.INF and USBSTOR.PNF. Check the value of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UsbStor\Start. It should be 4. It is also ok if the UsbStor key doesn't exist at all.
  9. On the same workstation, log off and back on as a user that should not have access to USB storage. Connect a USB memory stick or a similar device. Nothing should happen. Remove the memory stick.

10 . Log on as a user that should have access to USB storage and execute net start usbstor in a command shell or at Start – Run before connecting the memory stick. The memory stick should initialized and mapped to a drive letter. If USBSTOR fails to start, it's probably because this is the first time a memory stick is plugged into the workstation in which case USBSTOR is not yet installed. Nevertheless, the memory stick should be initialized and mapped correctly but you need to reboot in order to reapply the administrative template such that USBSTOR is disabled again. Alternatively, you can disable it manually by downloading and double clicking USBSTOR.REG as well as executing net stop usbstor.

11 . Instruct the users with access to USB storage that they need to execute net start usbstor before they can connect a USB storage device.

Source :http://diaryproducts.net/about/operating_systems/windows/disable_usb_sticks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.