Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just acquired a Wi-Fire long-range wi-fi adapter, and I would like to test it with my Ubuntu desktop computer. However, my machine defaults to using an internal, discrete wireless card (not hard-wired into the motherboard.) How can I set my new wireless adapter as the default wireless connection? How can I disable my internal wireless card (without opening my computer case)?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Your external and internal cards are unlikely to use the same kernel driver, so try blacklisting the module.

Do lspci | grep Network. This will output a line like

03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

In rare cases your wired adapter will be enumerated as a Network controller too (instead of Ethernet controller), so check the name of the device too. Probably it will contain 'wireless' or such. The XX:YY.Z number on start of line is the PCI slot number, record it for the next command.

Then do lspci -v -s XX:YY.Z | grep driver. It will output something like:

    Kernel driver in use: ath9k

ath9k in my case is the name of module that provides connectivity through built-in WiFi adapter. Execute the command echo "blacklist MODULE" >/etc/modprobe.d/blacklist-internal-wifi.conf in root shell, of course substituting MODULE with the driver name from previous step.

You can start the root shell by launching it in the menu or typing sudo su. It has a prompt ending in '#'.

Reboot, and you should have your internal adapter disabled. If you want to revert everything, just delete the /etc/modprobe.d/blacklist-internal-wifi.conf file

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.