Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been launching Xcode from Quicksilver quite happily for weeks. Suddenly late yesterday, without changing either Xcode or Quicksilver, it started appearing like this:

Screenshot

There's no "open" option in the action list anymore. I rebooted with no joy. All my other applications launch. Xcode still launches from Spotlight. It just seems to be any app under /Developer/Applications. Any suggestions?

share|improve this question

migrated from stackoverflow.com Jun 5 '10 at 20:15

This question came from our site for professional and enthusiast programmers.

    
try asking at superuser.com –  Jakub Hampl Jun 5 '10 at 19:33
    
Try rescanning your catalog: ⌘R –  churnd Jun 5 '10 at 23:25
    
Thanks, churnd. No luck. –  user39230 Jun 6 '10 at 19:18

2 Answers 2

When you use Quicksilver, it usually has various entries for an application: the application itself and other entries (such as the application's catalog). Notice here that you have selected the "Xcode.app (Catalog)", not "Xcode.app", which is the actual application.

Try hitting the down key to open the menu that lets you select other matching options for what you have typed in Quicksilver (in this case "Xc"). You may find the actual "Xcode.app" entry, which will let you open Xcode.

If that does not work, the problem may be that Quicksilver is not looking for applications in all your drive's folders. To solve that, open Quicksilver preferences and go to "Catalog > Applications". If the checkbox next to "Find All Applications" is unchecked, then check it.

share|improve this answer
    
Thanks, Genba. Unfortunately it is not in the list of available options and Find All Applications is indeed checked. It's strange because it found it fine at 5pm yesterday, but sometime after that it stopped. –  user39230 Jun 6 '10 at 19:18

In case somebody still has this problem, here are the steps I followed to fix it:

  1. Quit Quicksilver (ALT + Q double)
  2. Go to ~/Library/Caches/Quicksilver/Indexes
  3. Wipe out the cache files
  4. Run Quicksilver again and RESCAN catalog

Hope this helps!

(I found the solution in this post: http://www.mymacosx.com/fixes/quicksilver-application-catalog.html)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.