Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the following setup:

  • Desktop running Windows 7 RC (32-bit)
  • Xbox360 Elite with wireless adapter
  • Both devices are connected to a local wireless network (802.11n Draft 2.0 300Mbps)

I went through the setup procedure detailed on xbox.com, but after I enter the 8-character password - setup process times out after a few minutes.

I have tried disabling Windows firewall on the desktop, but that didn't help.

Has anyone been able to connect Xbox360 to Windows 7 RC over a 802.11-n (Draft 2.0) network? Any ideas on why the process is failing?

share|improve this question
    
I tried doing the media center thing with Vista and the xbox and it was a royal pain in the butt. I had to try it over and over again to get it to work. In the end, I never used it because it would stream any AVI files! Ridiculous. – Chris Thompson Jul 17 '09 at 5:42

Does it work on Vista? It does sound like it could be a Windows 7 issue. My Xbox used to connect to my Vista PC automatically.

share|improve this answer
    
Good point. I will try that. – Arnold Zokas Jul 15 '09 at 13:46

According to this knowledge base article the X-Box 360 does not work correctly on 802.11n and Draft-N wireless networks. I am assuming you are using the Wireless adapter for your X-Box based on your post.

I would suggest trying it temporarily using a wired connection and see if that works to eliminate the problem above.

On my wired network my Windows 7 box saw my X-Box directly and I just did the setup from there. The only reason I don't have it working at the moment is because of me re-segmenting my network and my X-Box is outside of the safe zone.

share|improve this answer
    
Thanks for the info! That definitely exlpains the problem. Unfortunately my console is too far away from the router, so wired connection is not an option. I guess I will have to wait for wireless-n to be officially supported. I am glad that at least the internet connection is working correctly. – Arnold Zokas Jul 17 '09 at 8:16
    
No problem. I ended up running a 20metre network cable in my old house to solve a similar problem. Wireless is just to slow for me. – BinaryMisfit Jul 17 '09 at 8:18
1  
That knowledge base article seems to show that the 360 won't be able to work at all using the network (no IP address). This seems like a different issue. Also, it sounds like your last paragraph refers to basic media sharing and not extender functionality (as I don't think you can setup the extender remotely like that). – Ryan Versaw Jul 17 '09 at 19:18
1  
@Ryan - I have done a few of these and it has always worked this way for me. I have over passed the information on to one of the X-Box MVP's and awaiting a response from MS. – BinaryMisfit Jul 17 '09 at 19:20
1  
I see. I've never used a wireless connection on mine, so my experience here is limited. @ArnieZ - Is your router an 802.11n-only router, or does it support other formats? If it is indeed 802.11n-only, then it appears that article should be updated. – Ryan Versaw Jul 17 '09 at 19:36

When doing this, are you connected to Xbox Live? When connecting to a Windows 7 (pre-RTM) Media Center PC a connection to Live is required.

If your connection to the PC was already setup and you tried connecting (without a connection to live), you would receive this message: This game requires a connection to Xbox LIVE. As you didn't receive this message, I'm guessing this isn't your issue, but when you're setting up the connection initially, it may be different.

share|improve this answer
    
Thanks - I find that interesting. I did a setup at my PM's house the other night without Internet and we got the Media Extender working on Windows 7 RC 32Bit. My home system is always connected to Live. – BinaryMisfit Jul 17 '09 at 19:37
    
Odd. That post didn't specifically mention the RC (only the beta), but the RC was out at the time and I saw commenters mention it having issues too. I'm surprised it worked fine for your PM! – Ryan Versaw Jul 17 '09 at 19:45
up vote 0 down vote accepted

Managed to get it working in the end by switching to an Ethernet connection.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .