Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just bought a Linksys Wireless-N PCI Adapter with Dual-Band, and I tried to log into the usual 2.4GHz 802.11n network with the usual pass key. Only now, the list says it's a 802.11g network and my pass key is incorrect.

Does anyone know this problem? And/Or how to fix it?

share|improve this question

Make sure WPA2 (AES-CCMP) is enabled on your 802.11n network. The 802.11n spec requires devices to decline connecting at N rates with WEP or TKIP (original WPA), because most implementations of those ciphers can't keep up with N rates. Not all N clients honor this requirement, but newer ones usually do, because the Wi-Fi Alliance's final N certification testing requires devices to honor it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .