Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I got tired of using the standard XFCE window manager, xfwm, I simply installed openbox and selected "XFCE/Openbox" session in the GDM login screen. This was very convenient because I didn't want the plain Openbox session in which there are no network-manager, no panels, nothing.

Now I have installed awesome: I really like the idea of tiling window managers. But after I launched it, everything went wrong. Absence of XFCE panels isn't anything bad, but subpixel-aliased fonts were somehow turned on, and that was really awful.

I tried to login in XFCE, kill openbox/xfwm and start awesome, but that didn't worked: xfce4-session keeps restarting it's predefined WM, and killing it kills the whole X session too. And I didn't found the configuration for a dropdown list in GDM either.

How can I start XFCE session with awesome as a WM?

share|improve this question
1  
I know this is a pretty old post, but can you post your .xinitrc and the GDM configuration files you had to change? I'd like to get this going, without the pain that you experienced. –  Bacon Feb 5 '12 at 20:15
    
@Bacon, simple: I've used .xsession instead (pastie.org/3326329). There's a GDM menu option for launching it in newer Debians. –  whitequark Feb 6 '12 at 8:52
add comment

2 Answers

up vote 3 down vote accepted

I might not be the right person to answer this, since I prefer Openbox partly because it doesn't set up panels and whatnot, but the section on xfce here seems like it might help you out.

The idea is that you configure your awesome session through that text file, and then link it to your "Xsession"

ln -s ~/.xinitrc ~/.Xsession

and then "select Xsession in your Session list at the login interface"

This is attacking it at a lower level than Ubuntu normally does, so there is possibly a more integrated way to do this. I'm also not totally sure what those commands will do, eg if they will actually cause the xfce panel to be displayed, but it seems worth a go at least.

share|improve this answer
    
The problem is, I don't have the xfce-settings-show command: everything xfce-ish I have begins with xfce4, and there is no xfce4-settings-show command anyway. So it will not configure anything, and I did not found any analogue of that command in recent xfce; appears that xfce4-session does that work itself. –  whitequark Jun 6 '10 at 18:52
    
hmmm... maybe this is relevant?: from /usr/share/doc/xfce4-session/README.Debian: If use you [sic] a login manager like GDM, you may have two ways to start Xfce : { - “Xfce Session” will run a complete xfce session . . . || - “Default session” will run whatever is the default session manager on your system. This is the /usr/bin/x-session-manager alternatives, meaning you can tune it with update-alternatives (8). If you only have Xfce installed on your system . . . it'll be a minimal one because all the preparation made in /etc/xdg/xfce4/xinitrc before running xfce4-session won't be done. } –  intuited Jun 6 '10 at 20:09
    
Also it might be possible to set something in ~/.config/xfce4-session/xfce4-session.rc... or maybe one of the other xfce4-settings-* commands has replaced the functionality of xfce-session-show. I suspect that what they're doing in that .xinitrc script is just starting something that happens to require minimal xfce functionality, and so the basic desktop starts up as kind of a side effect. A similar thing happens to me with GNOME under openbox if I start Nautilus or the gnome-settings-daemon, though in that case I don't get the panels, just the desktop and the GTK theme. –  intuited Jun 6 '10 at 20:15
    
Finally, I set everything up. While I did not used any of the XFCE daemons (GNOME ones are good enough), I did everything through .xinitrc (which I had to manually add to GDM's session list -- what a mess!), you posted the most close answer... wait, it's the single one! okay, it is close anyway, so accepted. –  whitequark Jun 14 '10 at 14:21
    
Cool, glad to hear it worked out. I was just trying to lead you onto the right path.. though perhaps you were already on it. –  intuited Jun 14 '10 at 23:26
add comment

This article from my own blog might help. Or the short version: Use

killall xfwm4 && awesome

It is as easy as that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.