Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This has happened before on my Vista Premium installation, and now it's happening on my Windows 7 Home Premium installation. Basically everytime I install Visual Studio Express 2010, it works fine for a random amount of time but then suddenly starts to hide from my sight -- that's the best way I can explain it. VS does not crash, and from what I can tell it does not freeze either; It continues to work, I can even "minimize" and "maximize" it; I simply cannot see it nor can I interact with it any meaningful way. Also:

  • After the "crash" there are no logs in: Root\Program Files (x86)\Microsoft Visual Studio 10.0\Microsoft Visual C++ 2010 Express - ENU. Nor any other files created at the time of the crash.

  • There are no traces in the event viewer.

  • The program seems to be functioning perfectly in the process manager.

  • If I reinstall Visual C++, it works normally for a seemingly random period of time before going cookoo again.

I am stumped. This has never happened to me before, with any other program. And yet I doubt it really is a problem with Visual C++; More like something general that seems to have picked on it for some reason. Still, after a clean install with a new OS, I'm kinda thinking there's something wrong here.

Any help would be appreciated, altough I suspect that the answer to this question will make me feel embarassed.

P.S. Not sure if it helps, but I think around the same time I started having problems (On both installations) with windows turning off the display when I leave the computer, and then seemingly crashing when it turns it on again -- in fact when I interact with it it seems to be responding to my commands without actually display anything.

share|improve this question

2 Answers 2

It could be a problem with your graphics hardware and/or drivers. Make sure you have the latest version of those drivers.

share|improve this answer
    
I run an update check on the video card and monitor drivers (for some reason I have two, H-W22 DVI and H-W22S), according to the device manager they are already up to date. I also brought up dxdiag, and according to it, directX11 is installed and working fine, unless there's something in particular I'm not seeing. –  Robert Vella Jun 6 '10 at 21:17
up vote 0 down vote accepted

Nevermind, here's what happened:

At some point, on my old installation, I installed a driver which gave me the ability to use two monitors at the same time -- the problem being of course that I don't have a second monitor. The catalyst might have been the installation of the service pack I needed to run VS 2010 on vista -- which mostly installs features which are inbuilt in Windows 7. This explains why the "problem" cropped up in both windows vista and then in my fresh installation of Windows 7.

Of course, there was never really a problem, the content was just being redirected to another display. When the display was turned on again, Windows was displaying the second monitor. When VC++ was debugging the program, it moved to the second monitor and stayed there.

Mystery solved ... I knew the answer to this question would make me feel embarassed.

P.S. If anyone else has this problem, the shortcut to switch monitor configurations in Windows 7 is [Windows Button] + P.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.