Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The checkbox that says "Use windows to configure my wireless network settings" keeps getting unchecked (Wirless Network Connection - Change advanced settings - Wireless networks tab.) How do I stop that from happening? (So the wi-fi will reconnect.) When I manually re-check the box, it automatically connects.)

I have a D-Link AirPremier DWL-G550 PCI adapter. I installed the newest driver, 5.3.0.46, and that didn't solve the problem. I took the "Atheros Client Utility" (the program window says "D-Link AirPremier Client Utility" when you run it) out of the start menu, rebooted, and that didn't solve the problem. (That utility puts a signal bar similiar to the one MS Windows puts there, and it's gone now.) The D-Link client utility has an option to automatically connect to preferred networks, but it is greyed out. It is also greyed out if I install the driver and utility right off the D-Link installation CD, so the problem isn't that the utility and driver are incompatible versions. I want to use Windows to handle the connection anyway, as the D-Link utility is garbage.

Windows XP SP3 w/all current updates.

share|improve this question
    
OT, but I agree that the D-Link utility is garbage. Literally. Clicking it just opens the built-in Windows dialog anyways (in XP at least). –  Hello71 Jun 6 '10 at 23:37

1 Answer 1

up vote 0 down vote accepted

I would uninstall the Atheros Client Utility and see if the driver remains. If the driver remains, you can set windows to configure the wireless network settings and it should hopefully remain.

If uninstalling the client utility does uninstall the driver (which you should be able to see in device manager) then you can see if you can find a standalone driver install. or you can unpack the .exe file (with 7-zip) that contains the driver and use windows to automatically install the driver for you and point it at the set of unpacked files from the .exe.

share|improve this answer
    
Brilliant. That worked. I pointed Windows to the driver installation folder for the driver, after uninstalling the program from Add/Remove programs (it deleted the driver too.) I had looked in the Device Manager to see if something was running related to this, but I didn't know which of them it might be. I thought ACU.exe would probably be the only one, and I got rid of that one. I guess there was another one (?). Thanks. –  greg88 Jun 6 '10 at 22:38
    
@greg88 Glad to hear it worked! –  James T Jun 7 '10 at 2:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.