Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded Ubuntu 9.10 x86_64 and am trying to install it on a fairly modern system with a Gigabyte GA-MA770-UD3 motherboard. Ubuntu 9.04 installed fine and still will when I stick that disc in, but 9.10 doesn't see my hard drive (western digital 250GB). If I boot from the disc, I can install gparted and it does recognize the drive, but when I try to start the install process from the live disc, Ubuntu again doesn't recognize the hard drive.

I checked /var/log/messages and see this:

Nov 12 17:28:08 ubuntu activate-dmraid: Serial ATA RAID disk(s) detected. If this was bad, boot with 'nodmraid'.
Nov 12 17:28:08 ubuntu activate-dmraid: Enabling dmraid support
Nov 12 17:28:08 ubuntu activate-dmraid: ERROR: either the required RAID set not found or more options required.
Nov 12 17:28:08 ubuntu activate-dmraid: ERROR: either the required RAID set not found or more options required.
Nov 12 17:28:08 ubuntu activate-dmraid: ERROR: either the required RAID set not found or more options required.
Nov 12 17:28:08 ubuntu activate-dmraid: no raid sets and with names: "nvidia_ciiajheb-0"
Nov 12 17:28:08 ubuntu activate-dmraid: ERROR: either the required RAID set not found or more options required.

I checked my BIOS, SATA is enabled and is set to IDE mode, so there shouldn't be software RAID, but nonetheless, I added nodmraid to the boot line and tried again. It still doesn't recognize the drive. I checked /var/log/messages again and now see this:

Nov 12 17:49:38 ubuntu activate-dmraid: Serial ATA RAID disk(s) detected. If this was boad, boot with 'nodmraid'.
Nov 12 17:49:38 ubuntu activate-dmraid: Enabling dmraid support
Nov 12 17:49:38 ubuntu activate-dmraid: WARNING: dmraid disabled by boot option
Nov 12 17:49:38 ubuntu activate-dmraid: WARNING: dmraid disabled by boot option

Any ideas on things to try? I've tried all of the various BIOS settings for SATA. IDE,RAID, etc. Nothing seems to work.

share|improve this question

migrated from serverfault.com Jun 7 '10 at 7:47

This question came from our site for system and network administrators.

    
Out of curiosity, is/was your drived plugged into one of the sata ports that can be used in the onboard raid? – David Mar 12 '10 at 3:05

This thread on the Ubuntu Forums appears to be relevant. The workaround discussed there is to remove the dmraid package before running the installer.

share|improve this answer

Have you tried setting it up as raid and initializing a raid volume? In general you would want to avoid software raid via that controller... perhaps delete any existing raid volume and try access without the dmraid controller, i.e nodmraid?

share|improve this answer
    
I haven't tried setting up raid, there's only 1 hard drive. I did try it without dmraid, at least, I think I did. I added nodmraid to the boot command. Is that not how you do it? – dan Nov 12 '09 at 22:00

I had such an issue when tried to install 9.10 on RAID-0. The thing I did: I installed terminal version of Ubuntu 9.04 from network, and upgraded it to 9.10. Also I made /boot ext3, and everything else was ext4. Seems like there's problem with the new brub2 + ext4 + some HDDs. Everything works fine: I'm writing this from 9.10 ;)

Try this hack until they release an update :)

share|improve this answer
    
I could install 9.04 and then upgrade, but being the inquisitive person that I am, I'd like to know why 9.04 recognizes my hard drive and 9.10 does not. ext3 vs ext4 boot partitions shouldn't cause the installer to not even recognize the hard drive right? – dan Nov 13 '09 at 1:01
    
I'm not sure. Just wanted to have a working system, and that was my way. ext4 may not be harmful for boot. Save your time, install 9.04: you're probably going to meet some grub2 bugs which are not fixable by humble users ;) – kolypto Nov 13 '09 at 1:31
    
ok, thanks for the advice! :) – dan Nov 13 '09 at 14:42
    
'thanks' does not affect reputation ;)) – kolypto Nov 13 '09 at 15:52

boot into live cd, apt-get remove dmraid, and start the installer from the live-cd desktop. Works a charm.

share|improve this answer
    
thanks, i'll try this the next time i get the opportunity to wipe the drive and start fresh. i just installed 9.04 and upgraded to 9.10. – dan Feb 19 '10 at 14:50

this did the trick:

  1. boot into the live CD (first option on the installer menu)
  2. open a terminal (Applications > Accessories > Terminal)
  3. enter this command: sudo apt-get -y remove dmraid
  4. run Install Ubuntu 9.10 from the desktop icon.
share|improve this answer

You must log in to answer this question.

protected by Jeff Atwood Jun 7 '10 at 7:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?