Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Remote Assistance working but not Remote Desktop.

XP Firewall has exceptions for both Remote Assistance and Remote Desktop. Remote Desktop is allowed in System Properties - Remote.

What could be the problem?

share|improve this question

3 Answers 3

Check

  • is the account having administrator right?
  • is the account having a password set?

to further clarify your question,

  • can you connect to the logon screen?
  • what is the error message?
share|improve this answer
    
I don't even get a login screen. Just a message saying that the connections was disconnected. –  CJ7 Jun 8 '10 at 8:27
    
Understood. Then check: (1) Can you ping the machine? (2) Can you connect to the port? (i.e. is the port in the remote computer open to you? use utilities such as nmap (google nmap).) Here, (1) If you can connect to the port, but unable to connect --> protocol problem. - then check RDP version, client setting, server setting e.g. is there forced encryption? (2) If you can't even connect, check firewall(s) in between. some ISP blocks RDP. –  bubu Jun 8 '10 at 15:37
    
remote assistance works between the 2 machines –  CJ7 Jun 9 '10 at 6:06

Things to try:

  • Verify that RDP is the same level on both machines.
  • Set the display's Hardware acceleration to None.
  • Update the display drivers to the latest versions (from the manufacturer's site).
share|improve this answer
    
What do you mean by "same level"? I can get Remote Assistance working so the firewalls are not blocking that port. –  CJ7 Jun 7 '10 at 14:09
    
@Craig Johnston: I mean that the RDP software is same version, although that's a somewhat long shot. As a remark: it wouldn't hurt to reinstall the RDP client, even if same version. I also erased the unsuitable port suggestion. –  harrymc Jun 7 '10 at 14:35

Make sure that Remote Desktop is enabled (it's a separate checkbox from Remote Assistance) and make sure that your version of windows includes Remote desktop - Home version does not, but Professional does.

share|improve this answer
    
As stated in the question, both machines are XP Pro. –  CJ7 Jun 8 '10 at 5:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.