Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Mac OS X Server 10.6, providing an L2TP VPN service. The VPN works just fine when connecting from all computers except one --- this one computer stays at the "Connecting..." stage for a while, then says "The L2TP-VPN server did not respond".

In the console, I see this:

 6/7/10 10:48:07 AM pppd[341]   pppd 2.4.2 (Apple version 412.0.10) started by jdoe, uid 503
 6/7/10 10:48:07 AM pppd[341]   L2TP connecting to server 'foo.bar.baz.edu' (256.256.256.256)...
 6/7/10 10:48:07 AM pppd[341]   IPSec connection started
 6/7/10 10:48:07 AM racoon[342] Connecting.
 6/7/10 10:48:07 AM racoon[342] IKE Packet: transmit success. (Initiator, Main-Mode message 1).
 6/7/10 10:48:08 AM racoon[342] IKE Packet: receive success. (Initiator, Main-Mode message 2).
 6/7/10 10:48:08 AM racoon[342] IKE Packet: transmit success. (Initiator, Main-Mode message 3).
 6/7/10 10:48:08 AM racoon[342] IKE Packet: receive success. (Initiator, Main-Mode message 4).
 6/7/10 10:48:08 AM racoon[342] IKE Packet: transmit success. (Initiator, Main-Mode message 5).
 6/7/10 10:48:11 AM racoon[342] IKE Packet: transmit success. (Phase1 Retransmit).
 6/7/10 10:48:14 AM racoon[342] IKE Packet: transmit success. (Phase1 Retransmit).
 6/7/10 10:48:17 AM racoon[342] IKE Packet: transmit success. (Phase1 Retransmit).

...and the "retransmit" messages continue until the error message pops up.

So far I've unsuccessfully tried:

  • rebooting
  • deleting the VPN profile and recreating it
  • verifying the client's internet connection (it is able to reach the VPN server)
  • connecting through several different networks (in case a router was blocking VPN packets)
  • disabling the Mac OS X Firewall on the client
  • making sure that the VPN settings exactly match those of other working computers
  • running software update (the client is on 10.6.3)

Any ideas?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Ah, I figured it out --- the "Shared Secret" "Machine Authentication" password was invalid. I reset it, and now it connects properly on all machines.

(Too bad the error message was totally incorrect. Hopefully someone else will find this before spending hours troubleshooting it... :^/ )

share|improve this answer
1  
Don't forget to accept your own answer. =-] –  Jack M. Jun 8 '10 at 19:59
add comment

protected by Diago Sep 23 '10 at 12:19

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.