Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem, everytime i plugin my external hard drive, its letter increase, "g,h,i,j,k,l,m, then n, and now o"
I went to computer manager and did what is described in this question: http://superuser.com/questions/76165/windows-changing-an-external-hard-drives-drive-letter
To change the drive letter, but i found that the letters from h to n are all missed and not in the list.

How to solve this problem?

I am using windows 7 ultimate edition 32.
2GB Ram.

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted
+150

It sounds like something is keeping the disk process open, so when you remove and then reattach the drive, which ever process it may be is preventing the letter from being reused. This could happen with processes like the index service or perhaps your AV program.

Take a look at this and see if it helps.

share|improve this answer
add comment

How have you disconnected the drive in the past?

If you've just unplugged it rather than using the "safely remove hardware" option Windows could think that the drive is still plugged in.

No real idea how to restore the missing drive letters though. I'm assuming that this behaviour survives a reboot of the laptop - not just an hibernate, but a full power off, power on cycle.

share|improve this answer
1  
i did a full power off power on but it kept the same, i just remember that in the last few days i was setting my laptop to sleep not to shut down and got that sometimes when i wake it up, it tell me that there is a new device attached while it was already attached before sleep. –  Amr ElGarhy Jun 7 '10 at 22:05
add comment

You might try to Turn off Hybrid sleep

See explanation here (for vista, but is the same).

share|improve this answer
add comment

Just a suggestion, but try formatting the external drive?

share|improve this answer
    
:) its very hard to this, i have a lot of files there, and why you think this will solve my issue? –  Amr ElGarhy Jun 13 '10 at 10:30
    
i'm not sure of my reasons, it may be a problem with the external drive and how it identifies itself to the computer...again, just a suggestion and a theory... –  studiohack Jun 13 '10 at 20:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.