Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Bought a new PC this weekend, and it works really good. Only I have one big problem: startup time. Its BIOS needs 62 sec to load, then from Grub start to pw entering screen it's another 26 sec. I think this is a lot, because my old PC needs 34 sec for BIOS and another 8 sec to pw screen. After I enter the pw, the desktop is usable with practically no delay on both.

The new PC is a core i7-930, running a Lucid Lynx 64 bit from a Intel Postville SSD (no internal HDs). The old PC is a Pentium 4 celeron (forgot the clock speed) running a Lucid Lynx 32 bit from an ATA 100 hard drive. Neither PC is overclocked. The new one has boot sequence 1.DVD ROM, 2.SSD (connected over SATA in AHCI mode), 3. removable drive. The old one boots from 1. DVD ROM, 2. HDD, 3. Floppy. Neither has a second OS installed. The new one has less software installed than the old one (I think), but the boot time difference was noticeable even before I made any installs.

As far as I know, just the SSD should be enough to make a noticeable difference in boot time. I thought that having a good mainboard on the new PC as opposed to the basic office model on the old one would also mean a faster loading BIOS. If these assumptions are right, I guess I must have misconfigured something in the BIOS of the new PC. How should I configure it for a fast boot? It has an ASUS P6X58D board with an AMI BIOS, if you need the BIOS revision number I could post that too.

UPDATE: I have two external HDDs, connected over USB 2.0. When the new PC is booted without them, the startup time falls to very reasonable 51 sec (button-push to pw screen). When I hook them to the old PC, they only make it boot 4 sec slower. Any ideas what to set up so they won't slow the boot process so much?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Your BIOS should have an option whether to check USB for boot devices. If you turn that off, you can leave your USB peripherals plugged in and keep your fast boot time.

As others have said, also look in the BIOS for "fast boot" or "quick check" and turn off any unused RAID options.

share|improve this answer
    
I think you were closest to the right answer. I'm not sure if the options I turned off did what you mention here, but it is possible (why won't asus write more than 1 sentence pro option in the manual?!) Anyway, it is 54 sec now and I'm happy with that. –  rumtscho Jun 9 '10 at 19:39
    
Thanks for the acknowledgment! –  kmarsh Jun 10 '10 at 12:15

Is the OS layout the same on both PCs?
Does grub have any timeout?
Have you tried putting the HDs as the first device in boot order? Have you tried using a different boot device (live CD) to see if loading to the livecd is quicker? Do you have significantly more memory in the new system (memory testing on boot can take a while).
Do you have any security such as bitlocker, truecrypt, etc?

There's just so many possiblities.

share|improve this answer
    
On both PCs, the OS takes up the entire disk in a single partition. Grub has no timeouts, and it is hidden too, by default booting to the OS without waiting for a user choice. Putting the HDD first doesn't change anything, but I'd removed the timeout for recognizing a bootable media in the DVD. Haven't tried LiveCD now, but at install, it took lots longer than a minute or two. I do have more memory (6 vs. 2 GB), but it is also much faster (DDR3 instead of DDR1). No encryption on any drive. –  rumtscho Jun 8 '10 at 8:58
    
Change to nogui boot and select how much CPU/core you got. Open start -> Run (windows+R) and type: msconfig. Here, at the Boot tab, click no GUI boot. Click on advanced, number of proc: 2 or 4... whatever. –  Shiki Jun 8 '10 at 10:00
    
Shiki, I am running Linux, so no msconfig. I could boot it without X, but don't see how that will help. I definitely don't have the typical Windows problem of too many programms starting and initializing together with the OS. –  rumtscho Jun 8 '10 at 11:16

BIOS typically have a full-checkup mode on power up, which takes considerably longer for it to verify everything is in working order. Usually that mode is not enabled, a default fast-boot mode speeds up boot-time checks by skipping a number of them.

Look through your BIOS options for anything related with start-up and verification tests.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.