Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've a strange problem with my ubuntu 10.04 installation. Whenever i boot into ubuntu the entire system freezes / hangs soon after (~ 2 mins in). This problem exists on my windows 7 installation too. However if i start World of Warcraft or Warcraft on windows it doesnt hang for the duration i'm playing the game. After i stop playing and exit the game my laptop hangs inside 2 mins. Here is when it gets weirder. If i disconnect the charger, the laptop doesn't hang. However when I start it in ubuntu recovery mode and drop to root shell and use the 'startx' command everything works perfectly. I cannot figure out what the problem is.

i have an intel core2duo 2.2ghz processor, intel mobile 965 graphics, 2 GB RAM

for more details here is the output of cat /proc/cpuinfo :

processor    : 0
vendor_id    : GenuineIntel
cpu family    : 6
model        : 15
model name    : Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz
stepping    : 11
cpu MHz        : 2201.000
cache size    : 4096 KB
physical id    : 0
siblings    : 2
core id        : 0
cpu cores    : 2
apicid        : 0
initial apicid    : 0
fdiv_bug    : no
hlt_bug        : no
f00f_bug    : no
coma_bug    : no
fpu        : yes
fpu_exception    : yes
cpuid level    : 10
wp        : yes
flags        : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm ida tpr_shadow vnmi flexpriority
bogomips    : 4389.80
clflush size    : 64
power management:

processor    : 1
vendor_id    : GenuineIntel
cpu family    : 6
model        : 15
model name    : Intel(R) Core(TM)2 Duo CPU     T7500  @ 2.20GHz
stepping    : 11
cpu MHz        : 2201.000
cache size    : 4096 KB
physical id    : 0
siblings    : 2
core id        : 1
cpu cores    : 2
apicid        : 1
initial apicid    : 1
fdiv_bug    : no
hlt_bug        : no
f00f_bug    : no
coma_bug    : no
fpu        : yes
fpu_exception    : yes
cpuid level    : 10
wp        : yes
flags        : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm ida tpr_shadow vnmi flexpriority
bogomips    : 4388.96
clflush size    : 64
power management:

here is the output of cat /proc/meminfo

MemTotal:        2052440 kB
MemFree:           55924 kB
Buffers:          579352 kB
Cached:           821752 kB
SwapCached:          704 kB
Active:           897124 kB
Inactive:        1032256 kB
Active(anon):     412140 kB
Inactive(anon):   264804 kB
Active(file):     484984 kB
Inactive(file):   767452 kB
Unevictable:           0 kB
Mlocked:               0 kB
HighTotal:       1178440 kB
HighFree:           6012 kB
LowTotal:         874000 kB
LowFree:           49912 kB
SwapTotal:        995988 kB
SwapFree:         986616 kB
Dirty:              8928 kB
Writeback:             0 kB
AnonPages:        527596 kB
Mapped:            76536 kB
Slab:              39480 kB
SReclaimable:      21100 kB
SUnreclaim:        18380 kB
PageTables:         5672 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:     2022208 kB
Committed_AS:    1856400 kB
VmallocTotal:     122880 kB
VmallocUsed:       11928 kB
VmallocChunk:     104644 kB
HugePages_Total:       0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       4096 kB
DirectMap4k:       16376 kB
DirectMap4M:      892928 kB

Also the kern.log doesn't show any errors. What I want to know is what might be the problem, how i could test for it and if there are any solutions I could try. Thanks :).

share|improve this question
    
any cards in cardreader, disks in DVD reader? IO is by far the most offender when it comes to mysterious freezes. –  vava Jun 8 '10 at 4:05
    
Recompile the kernel. –  ta.speot.is Jun 8 '10 at 4:16
    
blame it on the hard drive. –  James T Jun 8 '10 at 4:52
1  
Blame the kernel. :) –  Shiki Jun 8 '10 at 5:03
    
@taspeotis: So, it also effects Windows 7, should he also recompile that kernel? :D –  Bobby Jun 8 '10 at 8:57

1 Answer 1

up vote 2 down vote accepted

Sounds like a hardware problem (yeah, Cpt. Obvious is here). If the laptop still got warranty, use that. Wouldn't mess around with it (not like you could fix it).

Guess it's a problem with the power management. Inside the laptop that is. On Windows, it uses "Balanced" usually. When you go into the game, it tries to squeeze out everything from your lappy. On Linux if you start from recovery console, the performance governor won't start I guess. Try checking: cat /proc/cpuinfo | grep MHz from the recovery and from the normal start (well... at the normal start try to be fast. ;))


Note: Please, next time open a topic like: My laptop freezes. Ubuntu is OK , but its not a desktop OS and even freezes with a random Intel VGA. So... guess everyone starts to think about such a problem first. (Problem with the OS, not with the laptop.)


Workarounds:
On Windows, try setting your energy settings to performance. If that doesnt help, install BOINC. Join into the "World Community Grid" and that's it, convert your laptop into a hairdryer, AND you help important researches. Profit! :) (your pc works and you do a good thing)
On Linux: Guess you'd have to disable the governor with sudo service % stop (% = service name, like cups). Uhm check which is Ubuntu's governor. (ls /etc/init.d/) If you can't figure it out, post it here. But first, I would be happy with one (W7) half working OS until I get it into the service.

share|improve this answer
    
Thanks for the answer. It sounds logical enough. I will test it out and report back :). And sorry about the misleading question title. Will keep it in mind the next time. –  tapan Jun 8 '10 at 7:14
    
Ah no problem it was just an idea that you may get forward easier like that. BOINC will workaround the problem for sure since it literally uses all the resources you let it use. (You can set it in the options. Like always 50% cpu , or 85%, whatever. Check your CPU temperature with "SpeedFan" to make sure it won't overheat. Some laptop's cooling is simply crappy.) –  Shiki Jun 8 '10 at 7:23
    
+1, it could be that the CPU does support somekind of 0 MHz mode, were it is but to sleep or something. @tapan: Maybe you can add the CPU-Applet in Gnome to the panel and change the governor (left click) and see if that helps. –  Bobby Jun 8 '10 at 9:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.