Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to get source of `thinkfinger' package,

sudo apt-get source thinkfinger

But, it reports 403 error, and I found that it get the source from xxxx/pool/universe/t/thinkfinger/, but the correct location is in xxxx/pool/main/t/thinkfinger/.

So, is there any option for apt-get to specify which repository should it use?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

This should not happen at all just by design of APT, and so there is no method of specifying repository (there are methods of specifying release, but that is not the case).

Probably your local package cache got corrupted somehow, or just is out of date. Try doing sudo aptitude update.

share|improve this answer
    
Thanks. I have the repository mirrored to my portable disk, the problem is about symlink. In universe/ repository, the fingerprint-x.x-orig.tar.gz is linked to main/, and it is Apache forbid to serve the symlink. –  Xiè Jìléi Jun 8 '10 at 7:17
    
You should have noted that in your question, because it is impossible to guess that and, as a consequence, impossible to answer correctly. –  whitequark Jun 8 '10 at 14:55

In the origial Ubuntu repository thinkfinger isn't in main but in universe.

If you access the disc locally use file:// URLs instead of http:// URLs in /etc/apt/sources.list. If you need to access it via http enable symlink following for your repository directories.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.