Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Linux Ubuntu desktop at home, ssh enabled, vnc server installed, router rule configured. It all works, and at home I can connect via the local network from my Mac. From the outside I can login via ssh.

I've configured putty as follows:

  • session: host name and port number
  • connection > ssh > tunnel: forwarded ports: L5900|192.168.0.23
  • the local address is: 192.168.1.45

When I make the connection I can login to the remote machine.

Then I open Remote Desktop Viewer.

  • I click connect
  • protocol: vnc
  • host: ?
  • use host as ssh tunnel: ?

I don't know what to use for the last two options. Which ip-addresses should I use?

share|improve this question

migrated from stackoverflow.com Jun 8 '10 at 13:21

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 1 down vote accepted

SSH forwarding - you're forwarding from the host you have SSHed into, to the same host:

  • L5900|localhost:5900

VNC viewer:

  • host: localhost
  • "use host as ssh tunnel" is not needed, as you're doing that step (SSH forwarding) manually
share|improve this answer
    
Thank you! I got it working. –  SPRBRN Jun 8 '10 at 11:58

You should point your remote desktop viewer to the local address and local port number that you've chosen to bind to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.