Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu server with zoneminder installed. I only have one camera (cheap Logitech USB model) and it seems to be permanently idle.

I'm also getting this error repeatedly in the logs

06/06/2010 08:26:56.563783 zmwatch[28234].INF [Restarting capture daemon for main_room, shared memory not valid]
06/06/2010 08:26:56.812964 zmwatch[28234].INF ['zmc -d /dev/video0' starting at 10/06/06 08:26:56, pid = 29214]
06/06/2010 08:27:06.814486 zmwatch[28234].INF [Restarting capture daemon for main_room, shared memory not valid]
06/06/2010 08:27:07.054854 zmwatch[28234].INF ['zmc -d /dev/video0' starting at 10/06/06 08:27:07, pid = 29219]

I've already tried following the instructions in the FAQ for increasing shared memory, but that doesn't seem to work. What do I need to do to get this working?

Note: I have tested the camera with Linux via Cheese, and that works fine.

share|improve this question

migrated from serverfault.com Jun 8 '10 at 16:35

This question came from our site for professional system and network administrators.

    
Can you post your Zoneminder camera config, sysctl kernel.shmmax output and lsusb -v output relevant to camera? Let the pastebin help you. –  whitequark Jun 14 '10 at 13:22

1 Answer 1

This isn't really an answer, but maybe trying Motion and seeing if that works could reveal some more information that might help you zoom in on the problem?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.