Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I'm connected to a Windows XP computer from my Mac OS X 10.6 using the Citrix ICA Client, it seems that the shift key only works for the first letter typed after pressing shift. In order to type multiple uppercase letters, like ICA, I must either press caps lock, or press and release shift before each character.

I've tried switching between standard and enhanced keyboard, as well as the 'Send Special Keys Unchanged' option, but none of these seem to affect the issue. The problem doesn't occur when I switch from the Citrix window to a regular Mac window.

share|improve this question

I found on the Windows computer, I needed to go launch "Remote Desktop" and do the following:

When the Remote Desktop Connection screen opens, click on Options and then the Local Resources tab (right). In the Keyboard section, click the drop down menu arrow and select “On the local computer”. Then click on the General tab, followed by Save As.. and save your settings as “Default.rdp”. This will fix the “sticky keys” issue for both REMOTE DESKTOP and the Remote Desktop - RDP application.

share|improve this answer
    
Found the issue documented on the citrix site. Answer is as above. support.citrix.com/article/CTX110281 – Sandy May 2 '11 at 8:24

I am having the same problem. My receiver does not have the options shown on the Citrix site, so I have not found a resolution. In the meantime, my solution is to turn on "Sticky Keys" by typing 'Return' five times. That way, if I need to capitalize something, I type 'Return', then the key.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .