Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just read through this post and tried to get my installation back using this answer to no avail. What happened to me is this:

I spent an hour or more reading through the CloneZilla docs. I thought I was ready to test it out so I burned the disc with the ISO image on it and ran it. The system I used was Ubuntu 10.04, 32-bit.

Everything seemed to go fine. I made a clone of my first partition and copied it to my second partition. I followed the instructions, removed the disc and rebooted my system.

At this point, I would expect to have two bootable Linux installations, identical to one another. However, upon booting, I got this error message:

error: no such device: 4cf1a6ef-xxxx-xxxx-xxxx-4e3a3ce92bcd

error: file not found

I booted from a Live Ubuntu disc and was able to see my to partitions: 4cf1(1) and 4cf1(2) (abbreviated, because the volumes have long numbers to identify them). The 50 GB partition, on which the original Ubuntu installation sits is the number and the second partition (175 GB) is the same number with an "_" at the end. I could browse the disc partitions and see the files, but I'm not sure what to do next.

I know there is a way to restore my grub loader and actually boot either of these installations, but my Linux know-how is limited. Can I edit the boot loader file to fix this problem?

The only clue I have is CloneZilla said something about making a new GRUB but I thought it was going to basically modify it so I could boot either installation. Not sure what happened. I am going to look through this post for the time being to see if I can learn anything to help my problem. But I thought that, since this happened as a result of using CloneZilla, it may be a unique question for this board.

EDIT - Before I set up this copy using CloneZilla, I started another on a diffeent machine with Disk Copy from EaseUs. This took 6 hours to complete a 37 GB copy, from one hard disk to another. I shutdown the system and rebooted the original system fine (on the source drive). But when I tried to boot the clone (destination rive), I ran into the same error I described above - no such device.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I would suspect that grub is choking over two partitions with the same UUID, which your system seems to be using to identify the boot device (Ubuntu switched to this method some time ago). You can tell grub specifically to boot the first partition or the second partition by specifying the device in the configuration file. My Google-Fu is lacking at the moment, but what you'd want to do is force grub to a shell, manually boot the original partition, and modify the grub config to boot by device/partition until you can get the UUIDs straightened out. Also be mindful whether you're using Grub or Grub2, as I know Ubuntu switched over a few iterations ago.

share|improve this answer
1  
Thanks for the advice. I think it is grub2 at this point. What do you mean "force grub to a shell, manually boot the original partition?" I'm still learning the Linux jargon, so pardon my ignorance... –  nicorellius Jun 9 '10 at 3:19
1  
I'm not familiar with grub2, but for example, you could press c to get to the grub shell. From there you can manually mount the partition, specify the kernel, and tell it to boot the kernel. This should allow you to get your orginal system up for a single boot, during which you would fix your grub2 config files so that it works for subsequent boots. –  Darth Android Jun 9 '10 at 6:53
    
Another quick and dirty fix to get your system booting again would be to delete the new partition until you can find a way to make it have a different UUID, and recreate it at that point. This would however, destroy the work you've done so far. –  Darth Android Jun 9 '10 at 6:56
1  
I decided to reinstall Ubuntu 10.04. The system was newly installed anyway, mainly for testing purposes, so the quickest way to get it back up and running was to reinstall. Of course, I did lose all that work I put into the cloning. Your advice helped a lot, though, and I am making this post a favorite for future reference. On the EDIT above, the original disk booted fine, but the cloned one didn't, so I think I will practice these techniques on that disk. Thanks again. –  nicorellius Jun 9 '10 at 15:29
    
it'd probably be easier to edit the existing boot menu entry than input all the boot commands from a shell. highlight the entry you're trying to boot, press e, make changes, press Ctrl-X to boot (or just escape back to the menu and press enter to boot the entry). @nico –  quack quixote Jun 23 '10 at 20:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.