Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a hard drive whose Windows installation (running Vista) became corrupt. I bought a new hard drive, installed Windows 7, and hooked up the old drive using an external enclosure.

The Users folder on the old drive shows the users that existed on the machine, but it doesn't show any of the contents of them. I assume this is due to not having the permissions I need. I have "taken control" of the folders I'm interested in, but this didn't prompt me for the original owner's password as I expected, and I still can't see the file contents.

I would guess that this is a fairly common issue, but I'm not sure what to Google here. How can I get access to files in that drive's User directory?

share|improve this question
    
Note that you also need to be an administrator on the current computer, to avoid random users taking control of the whole filesystem. –  Hello71 Jul 23 '10 at 17:55

4 Answers 4

You will need to give "everyone" permissions to access the folders as the old users do not exist on the new machine.

NOTE: You will have to remove any other NTFS permissions on the folder before adding everyone and make sure you take ownership in a different session

alt text

alt text

share|improve this answer
1  
This gives me "Access Denied" –  JoshJordan Jun 9 '10 at 2:39
1  
Take ownership first, it will be owned by an unknown sid value (the old user sid), so take ownership, then ad users and change the permissions. –  Moab Apr 5 '11 at 3:36

I recently noticed similar behavior in my Windows 7 installation. After taking control/ownership, did you give yourself full control for "This folder, all subfolders and files"?

You might also try booting the system up with an Ubuntu Live CD and see if you can see the files that way, since it will be less inclined to enforce whatever security might be blocking the files.

share|improve this answer
    
Trying to give myself Full Control gives me an "Access denied" error. –  JoshJordan Jun 9 '10 at 2:34
1  
You might need to take ownership of the files before it will let you do that. If you do not have ownership, then it will not let you take full control. –  Darth Android Jun 9 '10 at 6:47

In Windows7, administrator account is hidden. You can enable the administrator account.

  1. Click start
  2. Program - Accessories- Right click on command prompt and select " Run as" administrator.
  3. In command prompt type command type net user administrator /active:yes

It will cure it. you will 2 user account one is administrator and your user. Now you can login to windows as administrator. Now you will modify the files or even delete it.

share|improve this answer

You need to take ownership if the folder and sub containers first, it will be owned by an unknown account SID.

Right click on the folder and select properties, then security Tab, then hit the Advanced Button.

Hit the edit button on the Advanced Security Settings window, then select your user account and tick the "replace owner on subcontainers and objects" Hit Ok, then hit OK to the pop up confirmation, Hit OK and close all properties windows. Once this is done do properties again and change permissions (if needed) for the user account you chose to Own the folders and any other accounts you need to.

In extreme cases use Explorer++ to view and change ownership of the folders and files, it is slightly less restrictive when it comes to Windows permissions to simply view folders owned by unknown accounts. http://www.explorerplusplus.com/

. enter image description here

. enter image description here

. enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.