Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a Swedish keyboard, and I want to be able to type braces easier.

I planned to map AltGr + å to '}' and AltGr + ä to '{'. However, nothing really changes. I have some other stuff in my.Xmodmap so I know that it gets loaded allright. Here's what I have so far:

keycode 35 = slash asciitilde dead_ogonek section dead_ogonek section
keycode 49 = asciicircum onehalf
keycode 66 = F10
clear Lock
keycode 34 = aring Aring braceleft
keycode 48 = adiaeresis Adiaeresis braceright 

Where the 2 last lines are the one that should be related to this. What could I be doing wrong?

Is there some other way I can solve it in Linux?

Update:

keycode 34 = aring Aring aring Aring braceleft dead_abovering
keycode 48 = adiaeresis Adiaeresis adiaeresis Adiaeresis braceright ae

Works fine.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted
+100

Have you tried

xmodmap -pke

and checked that these lines still appear in that form in the output? There could be other startup scripts that override some of your settings...

share|improve this answer
    
I ran xmodmap -pke (without having loaded my .Xmodmap rewrites), copy/pasted the output to .Xmodmap replacing the exact characters I wanted to replace with braces, and it now works! –  Jacob R Jun 22 '10 at 8:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.