Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using iTerm on OSX (leopard) to ssh to a linux machine. I run screen on the dev machine to save my work between sessions. I am not a big fan of audio bell and I don't like screen's default 'Wuff Wuff' bell (or any other little message shown at bottom of the page). What I like though is to have flash (foreground and blackground colors swapped for a fraction of a second) as my visual bell. I used to use PuTTY and it is as simple as ticking a checkbox but I can't find such an option in iTerm. My question is how can I set my visual bell to flash?

The ideal answer would work with iTerm on local computer, iTerm sshed to a linux server, and iTerm sshed to a linux server and ran screen.

share|improve this question

3 Answers 3

Sometimes the simplest things are the most tricky.

  1. Go to the preferences of iTerm.
  2. Go to the advanced section of your scheme (or those you use).
  3. Set visual bell and unset audio bell alt text That should work.
share|improve this answer

See my answer in this thread: the code change is already checked in and iTerm2 will have it in the next release.

share|improve this answer

In newer versions (I'm in 2.0.0.20141103 on OS X Yosemite), it looks like they moved the setting to Profiles > Terminal > (Default profile) > Terminal. This doesn't switch the foreground and background colors like you're asking for, but it does display a big visual bell in the middle of the terminal. It says I don't have enough reputation to post images, so see this link to an image of the settings page:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.