Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to work offline (I'm flying to the US twice this month), to do this I need access to a linux development server.

Update: After searching for a while, this is the same problem I'm experiencing (except with a Snow Leopard host and Ubuntu 10.04 guest).


When I work from home I boot a VirtualBox VM and that acts as my dev server for the day (providing Apache, PHP & MySQL to run my server side code). However, I'd like to work with my VM when I'm not connected to a network.

I have my Ubuntu VM guest set up with a bridge connection so it can serve HTTP and provide SSH access from inside my local network.

I've tried to manually configure my network settings on both Mac OSX (the host) and Ubuntu (the guest) but I can't even ping my own NIC address (127.0.0.1 can, 192.168.21.x I can't) in OS X when I unplug the cable.

Manual network settings:

$ ifconfig en0
en0: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
ether 00:xx:xx:xx:xx:xx 
inet 192.168.21.5 netmask 0xffffff00 broadcast 192.168.21.255
media: autoselect (100baseTX <full-duplex,flow-control>)
status: active

I can ping localhost fine, as well as my VM (.20) and SSH too.

$ ping 192.168.21.5
PING 192.168.21.5 (192.168.21.5): 56 data bytes
64 bytes from 192.168.21.5: icmp_seq=0 ttl=64 time=0.085 ms
64 bytes from 192.168.21.5: icmp_seq=1 ttl=64 time=0.102 ms
64 bytes from 192.168.21.5: icmp_seq=2 ttl=64 time=0.100 ms
64 bytes from 192.168.21.5: icmp_seq=3 ttl=64 time=0.094 ms

$ ping 192.168.21.20
PING 192.168.21.20 (192.168.21.20): 56 data bytes
64 bytes from 192.168.21.20: icmp_seq=0 ttl=64 time=0.910 ms
64 bytes from 192.168.21.20: icmp_seq=1 ttl=64 time=1.181 ms
64 bytes from 192.168.21.20: icmp_seq=2 ttl=64 time=1.159 ms
64 bytes from 192.168.21.20: icmp_seq=3 ttl=64 time=1.320 ms

Network cable unplugged:

$ ifconfig en0
en0: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
ether 00:xx:xx:xx:xx:xx 
media: autoselect
status: inactive

$ ping 192.168.21.5
PING 192.168.21.5 (192.168.21.5): 56 data bytes
ping: sendto: No route to host
ping: sendto: No route to host
Request timeout for icmp_seq 0
ping: sendto: No route to host
Request timeout for icmp_seq 1

Does OS X disable the NIC when the network cable is unplugged? Any way to stop it doing this?

share|improve this question
    
any reason you can't use an internal network for this? –  tombull89 Jun 9 '10 at 12:18
    
If an internal network allows the host to access the guest then I can't see why I couldn't use an internal network. –  Greg K Jun 9 '10 at 16:25

2 Answers 2

up vote 2 down vote accepted

Perhaps you can add an additional NIC to the guest, and configure it for Host-only Networking.

Host-only networking is another networking mode that was added with version 2.2 of VirtualBox. It can be thought of as a hybrid between the bridged and internal networking modes: as with bridged networking, the virtual machines can talk to each other and the host as if they were connected through a physical ethernet switch. Similarly, as with internal networking however, a physical networking interface need not be present, and the virtual machines cannot talk to the world outside the host since they are not connected to a physical networking interface.

share|improve this answer
    
The following blog post also looks helpful, although I'm unclear about the part on binding the host interface to tap0. callum-macdonald.com/2009/10/28/… –  Greg K Jun 9 '10 at 16:26
    
I'm pretty sure that the "binding the host interface to tap0" bit is something you have to do if Linux is your host OS, so it wouldn't necessarily apply to an OS X host. But since I run a Windows host, I can't speak authoritatively in any respect! –  coneslayer Jun 9 '10 at 17:42
    
I'm going to award you this question because Host Only networking is what I need. I'll open a separate question about configuration. –  Greg K Jun 13 '10 at 15:04

Just a thought but possibly a loopback adaptor might get round this. http://www.stayonline.com/detail.aspx?ID=1215

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.