Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running CRM 4.0 plugin for outlook 2007. When I open a link in outlook it launches in IE8 64-bit. This will not work because it appears some on the feature in CRM 4.0 do not work in IE 64-bit.

The default browser on the computer was FireFox. I change it to IE 32-bit and it is still behaving the same.

Does anyone have any ideas outlook why it is opening in 64-bit?

Is there a way to force Outlook to use the 32-bit version?

share|improve this question
    
Is the 64-bit version set as your default browser? –  ahsteele Jun 9 '10 at 17:43
    
no it is not. From what I understand you are not able to set the 64-bit version as the default browser. Firefox was the default browser ( outlook opens IE though ) –  Ken Jun 9 '10 at 17:48
add comment

3 Answers

Setting the Default program for internet browser did not work.
But when I went to "Control Panel\Programs\Default Programs\Set Associations" and changed the .url (Internet Shortcut) to open with "C:\Program Files (x86)\Internet Explorer\iexplorer.exe" it now opens links in Outlook with IE 32-bit.

share|improve this answer
add comment

Set default programs to IE8 32-bit. Start -> Default programs. Instead of clicking "Set your default programs", click the bottom link "Set program access and computer defaults". From there go to and select "custom" and select the appropriate programs and make sure to check the box on the right. "Allow access to this program"

share|improve this answer
    
Did that and it did not work. –  Ken Jun 9 '10 at 20:05
    
And you clicked Set program access and computer defaults and not Set your default programs? –  BloodPhilia Jun 9 '10 at 20:08
add comment

I ran into this problem when opening links in Outlook 2003 on Windows 7 64-bit. The links by default would open the 64-bit Internet Explorer 8 and therefore required third-party plug-ins would not be loaded.

I found a few places in the registry where the default IE is identified by its path and they need to be changed.

Copy the text below the dotted line (Windows Registry... should be first line copied) to notepad and save the file as IEdefaults.reg to your desktop. Double-click the file on your desktop to merge the registry information. Be sure to backup the registry beforehand, but all that’s being modified are the paths to Internet Explorer, where “ (x86)” is added next to Program Files. The locations can also be updated manually if you don’t want to create the registry file. Just find the locations in the registry and add “ (x86)” (without quotes).


Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_CLASSES_ROOT\htmlfile\shell\open\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\https\shell\open\command]
@="\"C:\\Program Files (x86)\\Internet Explorer\\iexplore.exe\" -nohome"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.