Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

my first time here, so I hope you can help. I've seen a lot of stuff on various forums (including here) about disabling the annoying "tap" function on a laptop touchpad. I learned the hard way not to uninstall the driver (as the software suggests), since you then lose the Synaptic tab in the mouse control settings, and with it all means to modify the touchpad settings ... incidentally, if this happens to you, reboot in safe mode and do a restore, and the Synaptic tab comes back. Not ideal, I know, but it works.

Anyway, I have the most up-to-date drivers, and I can go to the Synaptics tab and can disable the tap-to-click function no problem. However, next time the machine is booted, tap-to-click is back on. It can always be disabled, but it's a pain having to reset it every time the machine is powered up.

Is there a way to permanently disable it, once and for all?

share|improve this question
    
For information, this seems to be linked to Windows 7 somehow. I disabled the tap to click on my Dell (similar to Inspiron) laptop, and it doesn't come back, under XP. –  Gnoupi Jun 11 '10 at 13:24
    
Related questions: superuser.com/questions/79530/… and superuser.com/questions/80225/… –  Gnoupi Jun 11 '10 at 13:28

3 Answers 3

Sorted! In case anyone else hits the problem, here's how.

There's a batch of registry entries for each user's touchpad settings, as well as a single subset of these as a default (fortunately tapping on/off is in this subset). By trial and error (changing the settings in Control Panel, then seeing what effect it had on the registry settings), I discovered that modifying a user's touchpad settings changes their INDIVIDUAL registry entries (so each user can have a different profile), but the default remains the same. However, each time the machine is booted, every user's individual settings are copied from the default, overwriting any recent changes they may have made. I doubt the defaults were meant to be used this way (surely they should be more of a "factory reset" function?), but that's how things happen on our Inspiron.

To make the touchpad changes permanent, you need to change the defaults - AFAIK, this has to be done in regedit. For our model, it meant changing the value of "Gestures" from 7 to 6, tho it may vary for other machines. Of course, this will change the default (boot-time) touchpad profiles for EVERY user, but since both my wife and I detest tapping with a vengeance, this doesn't really matter.

I don't need to issue a warning about editing the registry manually ... but I hope this helps. In specific answer to Keiron, it's purely a personal preference. Nuff said?

share|improve this answer

I was literally ready to toss my Dell Inspiron N5010 in the trash because this problem was driving me INSANE! I did however (after who knows how many hours or I should say days) fix it! Here's the system I am running, the problem(s) I was having, and where I went to fix it. Laptop: Model: Dell Inspiron N5010 OS: Windows 7 Home Premium 64 bit Service Pack 1 Issue: After an update, I no longer had the option to turn of the "tap to enter" feature on the touchpad... in fact, I couldn't even see it anymore (it had changed the description to PS/2 Mouse, but there was NO option to turn that part off) Fix: I went here http://www.synaptics.com/resources/drivers and chose the drivers that matched my system, ran the install and it opened the settings window for the touchpad on my system. Not only did it now see it, but it also allowed me to turn it off. If you're having this issue, this fixed it for me and made me mad that I had wasted so much time looking for the right answer. I took bits and pieces from other forums and ended up putting them together to find the right drivers... hopefully this will stop you from pulling out your hair.

share|improve this answer

I don't know if you've had a blast at or maybe noticed this whilst sorting your particular touchpad glitches out Graham, but after having the same very annoying problems with not one, but 2 of my relatively new laptops, one an Asus, the other a Dell, I've found that, in my case anyway, both problems occured after several reinstalls of windows7, and at a point when I had, regrettably (in hindsight) felt I no longer needed to sit around waiting for automatic updates from neither Asus nor Dell. In Dells case, I too noticed the poor default settings for multiple user accounts, but after managing to re-engage the automatic product updates from Dell, I've not (touch wood) had any further problems, which as you probably may already have come accross, is NOT the case if you simply try to reinstall the touchpad drivers alone. The Asus on the other hand, works fine using either solution it would seem. Actual manufacturer's driver updates then, for me anyhow, seem to work, but in the Dells case, the automatic updates more so, even after each re-boot. I still tap the pad just to check, but if it did revert back to doing it again, I reckon I'd lose the plot altogether! lol

share|improve this answer

protected by Community Oct 6 '11 at 20:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.